码迷,mamicode.com
首页 > 其他好文 > 详细

zoj 3197 Google Book 【区间覆盖】

时间:2014-08-19 20:50:15      阅读:237      评论:0      收藏:0      [点我收藏+]

标签:区间覆盖

Time Limit: 1000MS   Memory Limit: 32768KB   64bit IO Format: %lld & %llu

[]   [Go Back]   [Status]  

Description

You, the best hacker in the world, want to download the books published on Google Book. After some investigation, you found that the address of each page consists of two parts. The first part is the page number, the second part is the signature which is unique for each page. To get the signature, you can send the query to the server. The query has one parameter, which indicates the page number. The server will return the signature of the required page, and it may also return the signature of some adjacent pages.

To minimize the bytes downloaded from the internet, and also make the server adminstrator hard to notice your "hack", you‘d like to minimize the number of queries

Input

The input has multiple cases.
The first line of the input is a single integer T which is the number of test cases. Then T consecutive test cases follow. In each test case, the first line is a number N (1<=N<=5000), indicating the number of pages of the book. Then n lines follows. On the i-th line, there will be two integers ai and bi (ai<=i<=bi). They indicate that the query for the i-th page will return the signatures from page ai to page bi (inclusive)

Output

Results should be directed to standard output. The output of each test case should be a single integer, which is the minimum number of queries to get all the signatures.

Sample Input

2
3
1 1
2 2
3 3
3
1 1
1 3
3 3

Sample Output

3
1

题意:每张纸要查询的时候需要从ai到bi,包含bi, 问你最少询问几次,能将从1~n的纸张都查完。

说来说去,这道题就是纯粹的区间覆盖问题。

所谓的区间覆盖就是找最少的区间将制定的区间覆盖掉。解法是:将ai(i:1~n)从大到小排序,相同的再按bi从大到小排序。 

具体做法看代码

代码:

#include <stdio.h>
#include <string.h>
#include <algorithm>
using std::sort;
struct node{
	int st, en;
}s[5004];
int cmp(node a, node b)
{
	if(a.st == b.st) return a.en > b.en;
	return a.st < b.st;
}
int main()
{
	int n, i, t, end;
	scanf("%d", &t);
	while(t --){
		scanf("%d", &n);
		for(i = 1; i <= n; i ++){
			scanf("%d%d", &s[i].st, &s[i].en);
		}
		sort(s+1, s+n+1, cmp);
		int end = s[1].st; //当前已选择的区间的右端
		int cou = 0;
		i = 1;
		while(end <= n&&i <= n){
			int temp = end; 
			while(s[i].st <= end){//选择左端小于当前最右端的右端最大的,+1, 然后在赋给end
				if(temp < s[i].en) temp = s[i].en;
				i++;
			}
			end = temp+1;//一定要加1,不加1的话 测试数据第一组过不去,仔细想想就知道
为什么要加1了			++cou;
		}
		printf("%d\n", cou);
	}
	return 0;
} 


zoj 3197 Google Book 【区间覆盖】,布布扣,bubuko.com

zoj 3197 Google Book 【区间覆盖】

标签:区间覆盖

原文地址:http://blog.csdn.net/shengweisong/article/details/38687445

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!