码迷,mamicode.com
首页 > 其他好文 > 详细

HDU1531 差分约束

时间:2017-02-02 18:20:19      阅读:221      评论:0      收藏:0      [点我收藏+]

标签:null   iso   find   save   others   symbols   ota   seq   ott   

King

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1564    Accepted Submission(s): 727


Problem Description
Once, in one kingdom, there was a queen and that queen was expecting a baby. The queen prayed: ``If my child was a son and if only he was a sound king.‘‘ After nine months her child was born, and indeed, she gave birth to a nice son. 
Unfortunately, as it used to happen in royal families, the son was a little retarded. After many years of study he was able just to add integer numbers and to compare whether the result is greater or less than a given integer number. In addition, the numbers had to be written in a sequence and he was able to sum just continuous subsequences of the sequence. 

The old king was very unhappy of his son. But he was ready to make everything to enable his son to govern the kingdom after his death. With regards to his son‘s skills he decided that every problem the king had to decide about had to be presented in a form of a finite sequence of integer numbers and the decision about it would be done by stating an integer constraint (i.e. an upper or lower limit) for the sum of that sequence. In this way there was at least some hope that his son would be able to make some decisions. 

After the old king died, the young king began to reign. But very soon, a lot of people became very unsatisfied with his decisions and decided to dethrone him. They tried to do it by proving that his decisions were wrong. 

Therefore some conspirators presented to the young king a set of problems that he had to decide about. The set of problems was in the form of subsequences Si = {aSi, aSi+1, ..., aSi+ni} of a sequence S = {a1, a2, ..., an}. The king thought a minute and then decided, i.e. he set for the sum aSi + aSi+1 + ... + aSi+ni of each subsequence Si an integer constraint ki (i.e. aSi + aSi+1 + ... + aSi+ni < ki or aSi + aSi+1 + ... + aSi+ni > ki resp.) and declared these constraints as his decisions. 

After a while he realized that some of his decisions were wrong. He could not revoke the declared constraints but trying to save himself he decided to fake the sequence that he was given. He ordered to his advisors to find such a sequence S that would satisfy the constraints he set. Help the advisors of the king and write a program that decides whether such a sequence exists or not.
 

 

Input
The input consists of blocks of lines. Each block except the last corresponds to one set of problems and king‘s decisions about them. In the first line of the block there are integers n, and m where 0 < n <= 100 is length of the sequence S and 0 < m <= 100 is the number of subsequences Si. Next m lines contain particular decisions coded in the form of quadruples si, ni, oi, ki, where oi represents operator > (coded as gt) or operator < (coded as lt) respectively. The symbols si, ni and ki have the meaning described above. The last block consists of just one line containing 0.
 

 

Output
The output contains the lines corresponding to the blocks in the input. A line contains text successful conspiracy when such a sequence does not exist. Otherwise it contains text lamentable kingdom. There is no line in the output corresponding to the last ``null‘‘ block of the input.
 

 

Sample Input
4 2
1 2 gt 0
2 2 lt 2
1 2
1 0 gt 0
1 0 lt 0 0
 

 

Sample Output
lamentable kingdom
successful conspiracy
 

 

Source
题意:
题意好迷。长度为n的序列,m个条件,输入条件
//运行spfa判断是否存在负环。注意题目中是b-a>c,b-a<c,差分约束要求>=或<=,因此要转化成b-a>=c+1,b-a<=c-1;
//可以都转换成>=的形式求最长路或<=的形式求最短路。加一个公共源点,每个点到他的距离为0。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
const int maxn=102,inf=0x7fffffff;
struct node
{
    int to,next,val;
} edge[maxn*4];//!
int mark[maxn],head[maxn],tot,dis[maxn],n,m,cnt[maxn];
void add(int a,int b,int c)
{
    edge[tot].to=b;
    edge[tot].next=head[a];
    edge[tot].val=c;
    head[a]=tot++;
}
bool spfa(int s)
{
    for(int i=0;i<=n+1;i++)
        dis[i]=-inf;
    memset(mark,0,sizeof(mark));
    memset(cnt,0,sizeof(cnt));
    queue<int>q;
    dis[s]=0;
    mark[s]=1;
    cnt[s]++;
    q.push(s);
    while(!q.empty())
    {
        int u=q.front();
        q.pop();
        mark[u]=0;
        for(int i=head[u]; i!=-1; i=edge[i].next)
        {
            int v=edge[i].to;
            if(dis[v]<dis[u]+edge[i].val)
            {
                dis[v]=dis[u]+edge[i].val;
                if(!mark[v])
                {
                    cnt[v]++;
                    if(cnt[v]>n+1) return false;//加上公共源点有n+2个点,入队n+2次时存在负环。
                    q.push(v);
                    mark[v]=1;
                }
            }
        }
    }
    return true;
}
int main()
{
    while(scanf("%d",&n)&&n){
        scanf("%d",&m);
        char ch[5];
        int a,b,c;
        memset(head,-1,sizeof(head));
        tot=0;
        for(int i=0;i<m;i++){
            scanf("%d%d%s%d",&a,&b,ch,&c);
            if(ch[0]==g) add(a-1,b+a,c+1);
            else add(b+a,a-1,1-c);
        }
        for(int i=0;i<=n;i++) add(n+1,i,0);
        if(spfa(n+1)) printf("lamentable kingdom\n");
        else printf("successful conspiracy\n");
    }
    return 0;
}

 

si,ni,gt/lt,ki表示a[si]+a[si+1]+......+a[si+ni]>/<Ki;问满足这m个条件的序列存在否。
代码:
 

HDU1531 差分约束

标签:null   iso   find   save   others   symbols   ota   seq   ott   

原文地址:http://www.cnblogs.com/--ZHIYUAN/p/6361382.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!