码迷,mamicode.com
首页 > 其他好文 > 详细

1061. 判断题(15)

时间:2017-02-08 14:18:35      阅读:190      评论:0      收藏:0      [点我收藏+]

标签:cst   turn   color   ems   log   std   names   code   cstring   

1061. 判断题(15)

判断题的评判很简单,本题就要求你写个简单的程序帮助老师判题并统计学生们判断题的得分。

输入格式:

输入在第一行给出两个不超过100的正整数N和M,分别是学生人数和判断题数量。第二行给出M个不超过5的正整数,是每道题的满分值。第三行给出每道题对应的正确答案,0代表“非”,1代表“是”。随后N行,每行给出一个学生的解答。数字间均以空格分隔。

输出格式:

按照输入的顺序输出每个学生的得分,每个分数占一行。

输入样例:
3 6
2 1 3 3 4 5
0 0 1 0 1 1
0 1 1 0 0 1
1 0 1 0 1 0
1 1 0 0 1 1
输出样例:
13
11
12

 

#include <iostream>
#include <cstring>
using namespace std;
int a[110][110];
int res[110];
int main(void)
{
    memset(res,0,sizeof(res));
    
    int n,m;
    cin>>n>>m;
    
    for(int index=0;index<n+2;index++) 
    {
        for(int j=0;j<m;j++)
        {
            cin>>a[index][j];
            if(index>=2&&a[1][j]==a[index][j])
            {
                res[index-2]+=a[0][j];
            }
        }
    }
    for(int i=0;i<n;i++)
    {
        cout<<res[i]<<endl;
    }
    return 0;
}

 

1061. 判断题(15)

标签:cst   turn   color   ems   log   std   names   code   cstring   

原文地址:http://www.cnblogs.com/xiongmao-cpp/p/6377701.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!