码迷,mamicode.com
首页 > 其他好文 > 详细

HDU_3496_(二维费用背包)

时间:2017-02-12 18:51:16      阅读:151      评论:0      收藏:0      [点我收藏+]

标签:center   sem   rip   get   select   ota   cep   from   stream   

Watch The Movie

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 7585    Accepted Submission(s): 2427


Problem Description
New semester is coming, and DuoDuo has to go to school tomorrow. She decides to have fun tonight and will be very busy after tonight. She like watch cartoon very much. So she wants her uncle to buy some movies and watch with her tonight. Her grandfather gave them L minutes to watch the cartoon. After that they have to go to sleep.
DuoDuo list N piece of movies from 1 to N. All of them are her favorite, and she wants her uncle buy for her. She give a value Vi (Vi > 0) of the N piece of movies. The higher value a movie gets shows that DuoDuo likes it more. Each movie has a time Ti to play over. If a movie DuoDuo choice to watch she won’t stop until it goes to end.
But there is a strange problem, the shop just sell M piece of movies (not less or more then), It is difficult for her uncle to make the decision. How to select M piece of movies from N piece of DVDs that DuoDuo want to get the highest value and the time they cost not more then L.
How clever you are! Please help DuoDuo’s uncle.
 

 

Input
The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by input data for each test case:
The first line is: N(N <= 100),M(M<=N),L(L <= 1000)
N: the number of DVD that DuoDuo want buy. 
M: the number of DVD that the shop can sale.
L: the longest time that her grandfather allowed to watch.
The second line to N+1 line, each line contain two numbers. The first number is the time of the ith DVD, and the second number is the value of ith DVD that DuoDuo rated.
 

 

Output
Contain one number. (It is less then 2^31.)
The total value that DuoDuo can get tonight.
If DuoDuo can’t watch all of the movies that her uncle had bought for her, please output 0.
 

 

Sample Input
1 3 2 10 11 100 1 2 9 1
 

 

Sample Output
3
 
 
题意:duoduo给N部片打了分,可以看L分钟片,店里只一次性卖M部片(最开始忽略了这个条件),每部片有长度,问duoduo在L分钟内看完这M部片可以的到的最高分。
 
读清了题还是不难。
 
 
代码:
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

int dp[1005][105];
int cost,val;
int n,m,l;

void zero_one(int cost,int val)
{
    
    for(int j=l;j>=cost;j--)
        for(int k=m;k>=1;k--)
            if(dp[j-cost][k-1]>=0)
                dp[j][k]=max(dp[j][k],dp[j-cost][k-1]+val);
}
int main()
{
    
    int t;
    scanf("%d",&t);
    while(t--)
    {
        memset(dp,-1,sizeof(dp));
        dp[0][0]=0;
        scanf("%d%d%d",&n,&m,&l);
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&cost,&val);
            zero_one(cost,val);
        }
        int res=0;
        for(int i=1;i<=l;i++)
            if(res<dp[i][m])
                res=dp[i][m];
        printf("%d\n",res);
    }
    return 0;
}

 

 
 

HDU_3496_(二维费用背包)

标签:center   sem   rip   get   select   ota   cep   from   stream   

原文地址:http://www.cnblogs.com/jasonlixuetao/p/6391398.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!