码迷,mamicode.com
首页 > 其他好文 > 详细

HDU3336 KMP+DP

时间:2017-02-20 18:19:08      阅读:164      评论:0      收藏:0      [点我收藏+]

标签:let   iostream   other   include   hdu3336   ber   ret   code   style   

Count the string

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9588    Accepted Submission(s): 4480


Problem Description
It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: "abab"
The prefixes are: "a", "ab", "aba", "abab"
For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.
 

 

Input
The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.
 

 

Output
For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.
 

 

Sample Input
1
4
abab
 

 

Sample Output
6
 

 

Author
foreverlin@HNU
题意:
求长度为n的字符串中每个前缀在这条字符串中出现的次数的总和

代码:

//dp[i]表示字符串s[1~i]中出现了多少个以s[i]为结尾的前缀,又有f数组的特性,如果
//f[i]=j则s[1~j]=s[i-j+1~i]得出状态转移方程dp[i]=dp[f[i]]+1;
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int mod=10007;
char P[200005];
int f[200005],dp[200005];
int main()
{
    int t,n;
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        scanf("%s",P);
        f[0]=f[1]=0;
        for(int i=1;i<n;i++){
            int j=f[i];
            while(j&&P[i]!=P[j]) j=f[j];
            f[i+1]=(P[i]==P[j]?j+1:0);
        }
        dp[0]=0;
        int sum=0;
        for(int i=1;i<=n;i++){
            dp[i]=dp[f[i]]+1;
            sum+=dp[i]%mod;
            sum%=mod;
        }
        printf("%d\n",sum);
    }
    return 0;
}

 

HDU3336 KMP+DP

标签:let   iostream   other   include   hdu3336   ber   ret   code   style   

原文地址:http://www.cnblogs.com/--ZHIYUAN/p/6420647.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!