码迷,mamicode.com
首页 > 其他好文 > 详细

堆(模板)

时间:2017-03-01 23:02:16      阅读:263      评论:0      收藏:0      [点我收藏+]

标签:依次   ++   load   names   表示   最小数   ios   aliyun   return   

题目描述

如题,初始小根堆为空,我们需要支持以下3种操作:

操作1: 1 x 表示将x插入到堆中

操作2: 2 输出该小根堆内的最小数

操作3: 3 删除该小根堆内的最小数

输入输出格式

输入格式:

 

第一行包含一个整数N,表示操作的个数

接下来N行,每行包含1个或2个正整数,表示三种操作,格式如下:

操作1: 1 x

操作2: 2

操作3: 3

 

输出格式:

 

包含若干行正整数,每行依次对应一个操作2的结果。

 

输入输出样例

输入样例#1:
5
1 2
1 5
2
3
2
输出样例#1:
2
5

说明

时空限制:1000ms,128M

数据规模:

对于30%的数据:N<=15

对于70%的数据:N<=10000

对于100%的数据:N<=1000000(注意是6个0。。。不过不要害怕,经过编者实测,堆是可以AC的)

样例说明:

技术分享

故输出为2、5

 

#include <algorithm>
#include <iostream>
#include <cstdio>

using namespace std;

int n,m,x,size;
int heap[1000005];

void push(int x)
{
    int now,next;
    heap[++size]=x;
    now=size;
    while(now>1)
    {
        next=now/2;
        if(heap[next]<=heap[now])    break;
        swap(heap[next],heap[now]);
        now=next;
    }
}

void pop()
{
    heap[1]=heap[size--];
    int now=1,next;
    while(now*2<=size)
    {
        next=now*2;
        if(next<size&&heap[next]>heap[next+1])    next++;
        if(heap[next]>=heap[now])    break;
        swap(heap[next],heap[now]);
        now=next;
    }
}

int main()
{
    scanf("%d",&n);
    while(n--)
    {
        scanf("%d",&m);
        if(m==1)
        {
            scanf("%d",&x);
            push(x);
        }
        if(m==2)
            cout<<heap[1]<<endl;
        if(m==3)
            pop();
    } 
    return 0;
}

 

堆(模板)

标签:依次   ++   load   names   表示   最小数   ios   aliyun   return   

原文地址:http://www.cnblogs.com/Shy-key/p/6486371.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!