码迷,mamicode.com
首页 > 其他好文 > 详细

A + B Problem II

时间:2017-03-09 23:07:23      阅读:226      评论:0      收藏:0      [点我收藏+]

标签:sample   break   tle   cee   name   void   nsis   namespace   strlen   

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

 

Sample Input
2 1 2 112233445566778899 998877665544332211
 

 

Sample Output
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
水题,但注意数组大小以及输入输出的方向。
#include<iostream>
#include<cstring>
using namespace std;
void add(char s1[],char s2[])
{
    int i,j,k;
    int a[1010],b[1010],len1,len2;
    memset(a,0,sizeof(a));
    memset(b,0,sizeof(b));
    len1=strlen(s1);
    len2=strlen(s2);
    j=0;
    for(i=len1-1;i>=0;i--)
        a[j++]=s1[i]-0;
        k=0;
    for(i=len2-1;i>=0;i--)
        b[k++]=s2[i]-0;
    for(i=0;i<1010;i++)
    {    a[i]+=b[i];
        if(a[i]>=10)
        {
            a[i]-=10;
            a[i+1]++;
        }
    }
    for(i=1005;i>=0;i--)
    {
        if(a[i]) break;
    }
    for( ;i>=0;i--)
    cout<<a[i];
}
int main()
{
    int i;
    char c[1010];
    char d[1010];
    int n;
    cin>>n;
    for(i=1;i<=n;i++)
    {
         cin>>c>>d;
         cout<<"Case "<<i<<":"<<endl;
         cout<<c<<" +"<< <<d<<" ="<< ;
         add(c,d);
         cout<<endl;
         if(i!=n)
         cout<<endl;
    }
    return 0;
}

 

A + B Problem II

标签:sample   break   tle   cee   name   void   nsis   namespace   strlen   

原文地址:http://www.cnblogs.com/shinianhuanniyijuhaojiubujian/p/6528204.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!