码迷,mamicode.com
首页 > 其他好文 > 详细

1067. 试密码(20)

时间:2017-03-19 17:03:55      阅读:339      评论:0      收藏:0      [点我收藏+]

标签:gpl   inpu   空格   不包含   vector   end   char   就会   tab   

1067. 试密码(20)

当你试图登录某个系统却忘了密码时,系统一般只会允许你尝试有限多次,当超出允许次数时,账号就会被锁死。本题就请你实现这个小功能。

输入格式:

输入在第一行给出一个密码(长度不超过20的、不包含空格、Tab、回车的非空字符串)和一个正整数N(<= 10),分别是正确的密码和系统允许尝试的次数。随后每行给出一个以回车结束的非空字符串,是用户尝试输入的密码。输入保证至少有一次尝试。当读到一行只有单个#字符时,输入结束,并且这一行不是用户的输入。

输出格式:

对用户的每个输入,如果是正确的密码且尝试次数不超过N,则在一行中输出“Welcome in”,并结束程序;如果是错误的,则在一行中按格式输出“Wrong password: 用户输入的错误密码”;当错误尝试达到N次时,再输出一行“Account locked”,并结束程序。

输入样例1:

Correct%pw 3
correct%pw
Correct@PW
whatisthepassword!
Correct%pw
#

输出样例1:

Wrong password: correct%pw
Wrong password: Correct@PW
Wrong password: whatisthepassword!
Account locked

输入样例2:

cool@gplt 3
coolman@gplt
coollady@gplt
cool@gplt
try again
#

输出样例2:

Wrong password: coolman@gplt
Wrong password: coollady@gplt
Welcome in
#include <iostream>
#include <iomanip>
#include <math.h>
#include <stdio.h>
#include <string>
#include <algorithm>
#include <vector>
#include <map>
using namespace std;


int main()
{
    string ans,temp;
    int n,cnt=0;
    cin >> ans >> n;
    vector<string> input(n);
    getchar();
    while (1)
    {
        getline(cin, temp);
        if (temp != "#") cnt++;
        else break;
        if (cnt <= n&&temp == ans)
        {
            cout << "Welcome in"<<endl;
            break;
        }
        else if (cnt <= n&&temp != ans)
        {
            cout << "Wrong password: " << temp << endl;
            if (cnt == n)
            {
                cout << "Account locked" << endl; break;
            }
        }
    }
    
    
    
    
    system("pause");
    return 0;
}

 



1067. 试密码(20)

标签:gpl   inpu   空格   不包含   vector   end   char   就会   tab   

原文地址:http://www.cnblogs.com/brightz2017/p/6580704.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!