码迷,mamicode.com
首页 > 其他好文 > 详细

HDU-2138 How many prime numbers

时间:2017-03-26 18:17:41      阅读:196      评论:0      收藏:0      [点我收藏+]

标签:clu   ios   out   esc   blog   cin   cout   numbers   name   

 

Description

 Give you a lot of positive integers, just to find out how many prime numbers there are.

 

Input

There are a lot of cases. In each case, there is an integer N representing the number of integers to find. Each integer won’t exceed 32-bit signed integer, and each of them won’t be less than 2.

 

Output

For each case, print the number of prime numbers you have found out.

 

Sample Input

3

2 3 4

 

Sample Output

2


判断到sqrt(n)即可。

 

#include <iostream>
#include <cmath>
using namespace std;

int main(void)
{
    int t;
    long num[2000];
    
    while(cin >> t)
    {
        int s = 0;
        for(int i = 0; i < t; i++)
        {
            cin >> num[i];
            for(long j = 2; j <= sqrt(num[i]; j++)
            {
                if(num[i] % j == 0)
                {
                    s++;
                    break;
                }
            }
        }
        cout << t-s << endl;
    }
    return 0;
}

 

HDU-2138 How many prime numbers

标签:clu   ios   out   esc   blog   cin   cout   numbers   name   

原文地址:http://www.cnblogs.com/limyel/p/6623386.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!