码迷,mamicode.com
首页 > 其他好文 > 详细

Choose the best route 【Dijkstra】

时间:2017-03-27 23:58:37      阅读:330      评论:0      收藏:0      [点我收藏+]

标签:return   void   integer   express   main   define   max   tput   minutes   

Problem Description
One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.

Input
There are several test cases.
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.

Output
The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.

Sample Input
5 8 5
1 2 2
1 5 3
1 3 4
2 4 7
2 5 6
2 3 5
3 5 1
4 5 1
2
2 3
4 3 4
1 2 3
1 3 4
2 3 2
1
1

Sample Output
1
-1
来源: http://acm.hdu.edu.cn/showproblem.php?pid=2680


大意:主人公搭公交车到朋友家,求最少需要多少时间?

题解:有一个非常隐蔽的地方,means from station p to station q there is a way and it will costs t minutes . 特指从p到q,暗示是单向的。

#include<stdio.h>
#include<string.h>
#define INF 999999999
#include<algorithm>
using namespace std;
int n,m,s;
int dis[1001];
int map[1001][1001];
int vis[1001];
int c;
void Dijkstra(){
	int u;
	memset(vis,0,sizeof(vis));
	for(int i=0;i<=c;i++){
		dis[i] = map[0][i];
	}
	vis[0] = 1;
	int min = INF;
	for(int i=1;i<=c;i++){
		min = INF;
		for(int j=1;j<=c;j++){
			if(vis[j] == 0 && dis[j] < min){
				min = dis[j];
				u = j;
			}
		}
		vis[u] = 1;
		for(int v=1;v<=c;v++){
			if(map[u][v] < INF){
				if(dis[v] > dis[u] + map[u][v]){
					dis[v] = dis[u] + map[u][v];
				}
			}
		}	
	}
}
int main(){
	int p,q,t;
	while(~scanf("%d %d %d",&n,&m,&s)){
		
		for(int i=0;i<1001;i++){
			for(int j=0;j<1001;j++){
				map[i][j] = INF;
			}
			map[i][i] = 0;
		}
		
		for(int i=0;i<m;i++){
			scanf("%d %d %d",&p,&q,&t);
			c = max(max(c,p),q);
			if(t < map[p][q]){
				map[p][q] = t;
			}
		}
		int m,w;
		scanf("%d",&m);
		for(int i=0; i<m; i++){  
            scanf("%d",&w);  
            map[0][w] = 0;
        }  
        Dijkstra();
        if(dis[s] < INF)
			printf("%d\n",dis[s]);
		else
			printf("-1\n");
	}
	return 0;
}

  

 

Choose the best route 【Dijkstra】

标签:return   void   integer   express   main   define   max   tput   minutes   

原文地址:http://www.cnblogs.com/redscarf/p/6629473.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!