码迷,mamicode.com
首页 > 其他好文 > 详细

UVA - 1478 Delta Wave (大数+卡特兰数)

时间:2014-08-23 17:48:51      阅读:275      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   java   os   io   for   ar   div   

Description

bubuko.com,布布扣

A delta wave is a high amplitude brain wave in humans with a frequency of 1 - 4 hertz which can be recorded with an electroencephalogram (EEG) and is usually associated with slow-wave sleep (SWS).

- from Wikipedia

The researchers have discovered a new kind of species called ``otaku", whose brain waves are rather strange. The delta wave of an otaku‘s brain can be approximated by a polygonal line in the 2D coordinate system. The line is a route from point (0, 0) to (N, 0), and it is allowed to move only to the right (up, down or straight) at every step. And during the whole moving, it is not allowed to dip below the y = 0 axis.

For example, there are the 9 kinds of delta waves for N = 4:

bubuko.com,布布扣

Given N, you are requested to find out how many kinds of different delta waves of otaku.

Input

There are no more than 20 test cases. There is only one line for each case, containing an integer N (2 < Nbubuko.com,布布扣10000)

Output

Output one line for each test case. For the answer may be quite huge, you need only output the answer module 10100.

Sample Input

3 
4

Sample Output

4 
9
题意:从坐标(0, 0)到(n, 0)的折线,这条折线每向右延伸一个单位长度,高度要么不变,要么+1,要么-1,已知n,求这种折线种数
思路:我们知道上升和下降的次数要一样,而这就像卡特兰数的入栈出栈次序一样,所以我们从n中选出2k次进行类出栈模拟,
那么ans[k] = C[n][2k]*C[2k][k]/(k+1),然后我们可以相除两式递推出结果是ans[k] = ans[k-1]*(n-2*k+2)*(n-2*k+1)/(k*(k+1)) 
import java.io.*;
import java.util.*;
import java.math.*;

public class Main{
	public static void main(String args[]){
		Scanner cin = new Scanner(System.in);
		BigInteger mod = BigInteger.ONE;
		for (int i = 1; i <= 100; i++)
			mod = mod.multiply(BigInteger.valueOf(10));
		while (cin.hasNext()) {
			int n = cin.nextInt();
			if (n == 0)
				break;
			BigInteger it = BigInteger.ONE;
			BigInteger ans = BigInteger.ONE;
			for (int i = 0; i < n/2; i++) {
				it = it.multiply(BigInteger.valueOf((n-2*i)*(n-2*i-1)));
				it = it.divide(BigInteger.valueOf((i+1)*(i+2)));
				ans = ans.add(it);
			}
			System.out.println(ans.mod(mod));
		}
	}
}


UVA - 1478 Delta Wave (大数+卡特兰数)

标签:des   style   http   java   os   io   for   ar   div   

原文地址:http://blog.csdn.net/u011345136/article/details/38779391

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!