码迷,mamicode.com
首页 > 其他好文 > 详细

Asteroids!-裸的BFS

时间:2017-04-14 20:29:35      阅读:198      评论:0      收藏:0      [点我收藏+]

标签:cep   present   raft   series   blank   mono   back   hit   ==   

G - Asteroids!
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

You‘re in space. 
You want to get home. 
There are asteroids. 
You don‘t want to hit them. 
 

Input

Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets. 

A single data set has 5 components: 

Start line - A single line, "START N", where 1 <= N <= 10. 

Slice list - A series of N slices. Each slice is an N x N matrix representing a horizontal slice through the asteroid field. Each position in the matrix will be one of two values: 

‘O‘ - (the letter "oh") Empty space 

‘X‘ - (upper-case) Asteroid present 

Starting Position - A single line, "A B C", denoting the <A,B,C> coordinates of your craft‘s starting position. The coordinate values will be integers separated by individual spaces. 

Target Position - A single line, "D E F", denoting the <D,E,F> coordinates of your target‘s position. The coordinate values will be integers separated by individual spaces. 

End line - A single line, "END" 

The origin of the coordinate system is <0,0,0>. Therefore, each component of each coordinate vector will be an integer between 0 and N-1, inclusive. 

The first coordinate in a set indicates the column. Left column = 0. 

The second coordinate in a set indicates the row. Top row = 0. 

The third coordinate in a set indicates the slice. First slice = 0. 

Both the Starting Position and the Target Position will be in empty space. 

 

Output

For each data set, there will be exactly one output set, and there will be no blank lines separating output sets. 

A single output set consists of a single line. If a route exists, the line will be in the format "X Y", where X is the same as N from the corresponding input data set and Y is the least number of moves necessary to get your ship from the starting position to the target position. If there is no route from the starting position to the target position, the line will be "NO ROUTE" instead. 

A move can only be in one of the six basic directions: up, down, left, right, forward, back. Phrased more precisely, a move will either increment or decrement a single component of your current position vector by 1. 

 

Sample Input

START 1 O 0 0 0 0 0 0 END START 3 XXX XXX XXX OOO OOO OOO XXX XXX XXX 0 0 1 2 2 1 END START 5 OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO XXXXX XXXXX XXXXX XXXXX XXXXX OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO 0 0 0 4 4 4 END
 

Sample Output

1 0 3 4 NO ROUTE
 
/*
Author: 2486
Memory: 1452 KB		Time: 0 MS
Language: G++		Result: Accepted
*/
#include <cstring>
#include <algorithm>
#include <queue>
using namespace std;
const int maxn=+5;
char maps[maxn][maxn][maxn];
bool vis[maxn][maxn][maxn];
char op[10];
int n;
int a[10];
int dx[]={0,0,1,0,-1,0};
int dy[]={0,0,0,1,0,-1};
int dz[]={1,-1,0,0,0,0};
struct obje{
    int x,y,z,steps;
    obje(int x,int y,int z,int steps):x(x),y(y),z(z),steps(steps){}
    bool operator<(const obje &a)const{
        return steps>a.steps;
    }
};
void bfs(){
    priority_queue<obje>G;
    G.push(obje(a[0],a[1],a[2],0));
    while(!G.empty()){
        obje e=G.top();
        G.pop();
        if(e.x<0||e.y<0||e.z<0||e.x>=n||e.y>=n||e.z>=n||maps[e.x][e.y][e.z]==‘X‘||vis[e.x][e.y][e.z])continue;
        vis[e.x][e.y][e.z]=true;
        if(e.x==a[3]&&e.y==a[4]&&e.z==a[5]){
            printf("%d %d\n",n,e.steps);
            return;
        }
        for(int i=0;i<6;i++){
            int nx=e.x+dx[i];
            int ny=e.y+dy[i];
            int nz=e.z+dz[i];
            G.push(obje(nx,ny,nz,e.steps+1));
        }
    }
    printf("NO ROUTE\n");
}
int main(){
    #ifndef ONLINE_JUDGE//本博客有介绍其用处
    freopen("D://imput.txt","r",stdin);
    #endif // ONLINE_JUDGE
while(~scanf("%s%d",op,&n)){
    for(int i=0;i<n;i++){
        for(int j=0;j<n;j++){
                scanf("%s",maps[i][j]);
        }
    }
    for(int i=5;i>=0;i--){
        scanf("%d",&a[i]);
    }
    scanf("%s",op);
    bfs();
}
return 0;
}


Asteroids!-裸的BFS

标签:cep   present   raft   series   blank   mono   back   hit   ==   

原文地址:http://www.cnblogs.com/zsychanpin/p/6710645.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!