码迷,mamicode.com
首页 > 其他好文 > 详细

CSUOJ1867

时间:2017-04-23 01:17:58      阅读:425      评论:0      收藏:0      [点我收藏+]

标签:desc   href   return   scanf   ems   find   inpu   sub   second   

1867: John and Health rate

  Time Limit: 2 Sec     Memory Limit: 128 Mb     Submitted: 328     Solved: 77    


 

Description

The cold and flu season is here.John is worried about his cow. In order to monitor the situation of his cow,he do some inspecting everyday,and record the “health rate” for each cow.The “health rate” is a integer which can show the cow’s health condition.The higher a cow’s health rate is ,the healthier the cow is.What’s more,the doctor told John that the k-th small health rate is dangerous.Because the doctor thought there are at most k healthy cows. So John has to find out which number is the k-th small.Can you help him?

Input

Input contains multiple test cases.
The first line contains two integers n,k (1?≤?n?≤?1000000,1<=k<=n) — the number of cows and dangerous number. The second line contains n integers,and the i-th integer ai(-10000<=ai<=10000) is the i-th cow’s health rate

Output

Output a single line with the k-th small health rate.

Sample Input

2 1
3 2
5 2
-1 0 -2 5 3

Sample Output

2
-1



其实很简单,就用一个sort就可以解决,时间复杂度为O(nlogn),最小的时间复杂度要用到桶排序?

#include <iostream>
#include<cstdio>
#include<algorithm>
using namespace std;

int n,k,a[1000000];

int main()
{
    while(~scanf("%d%d",&n,&k)){
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        sort(a,a+n);
         printf("%d\n",a[k-1]);
    }
    return 0;
}

 




CSUOJ1867

标签:desc   href   return   scanf   ems   find   inpu   sub   second   

原文地址:http://www.cnblogs.com/umrx/p/6750162.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!