码迷,mamicode.com
首页 > 其他好文 > 详细

POJ1328 Radar Installation 【贪心·区间选点】

时间:2017-04-24 21:13:51      阅读:149      评论:0      收藏:0      [点我收藏+]

标签:out   each   its   分享   case   jin   inf   cart   center   

Radar Installation
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 54593   Accepted: 12292

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
技术分享 
Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

Source


#include <stdio.h>
#include <string.h>
#include <math.h>
#include <algorithm>

#define maxn 1010
using namespace std;

struct Node {
    double u, v;
    friend bool operator<(const Node& a, const Node& b) {
        return a.u < b.u;
    }
} E[maxn];
int N, D;

int main() {
    int i, ok, id, ans, cas = 1;
    double x, y, d, flag;
    while(scanf("%d%d", &N, &D), N) {
        printf("Case %d: ", cas++);
        ok = 1; id = 0;
        for(i = 0; i < N; ++i) {
            scanf("%lf%lf", &x, &y);
            if(y > D) ok = 0;
            if(!ok) continue;
            d = sqrt(D * D - y * y);
            E[id].u = x - d;
            E[id++].v = x + d;
        }

        if(!ok) {
            printf("-1\n");
            continue;
        }

        sort(E, E + id);

        flag = E[0].v; ans = 1;
        for(i = 1; i < N; ++i) {
            if(E[i].u <= flag) {
                if(E[i].v <= flag) flag = E[i].v;
                continue;
            }
            ++ans; flag = E[i].v;
        }

        printf("%d\n", ans);
    }
    return 0;
}


POJ1328 Radar Installation 【贪心&#183;区间选点】

标签:out   each   its   分享   case   jin   inf   cart   center   

原文地址:http://www.cnblogs.com/yutingliuyl/p/6758699.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!