码迷,mamicode.com
首页 > 其他好文 > 详细

Problem H: STL——括号匹配

时间:2017-04-27 19:48:10      阅读:159      评论:0      收藏:0      [点我收藏+]

标签:字符   include   nbsp   str   括号匹配   bsp   esc   data   script   

Description

给出一堆括号,看其是否匹配,例如 ()、()()、(()) 这样的括号就匹配,
      )(、)()) 而这样的括号就不匹配

Input

每一行代表一组测试样例,每组测试样例只包含‘(‘和‘)‘,样例长度不超过100个字符

Output

如果所有的括号都匹配,那么输出YES,否则输出NO

Sample Input

() )(

Sample Output

YES NO

HINT

使用STL的stack容易实现。

 

#include <iostream>
#include <algorithm>
#include <stack>
#include <string>
using namespace std;
int main()
{
    string s;
    stack<int> sta;
    while(cin>>s)
    {
        while(!sta.empty())
            sta.pop();
        int len=s.size();
        for(int i=0;i<len;i++)
        {
            if(s[i]==‘(‘)
                sta.push(1);
            else
            {
                if((!sta.empty()) && (sta.top()==1))
                    sta.pop();
                else
                    sta.push(0);
            }
        }
        if(!sta.empty())
            cout<<"NO"<<endl;
        else
            cout<<"YES"<<endl;
    }
}

 

Problem H: STL——括号匹配

标签:字符   include   nbsp   str   括号匹配   bsp   esc   data   script   

原文地址:http://www.cnblogs.com/masterchd/p/6775529.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!