码迷,mamicode.com
首页 > 其他好文 > 详细

[HDU1000] A + B Problem

时间:2017-04-29 23:28:38      阅读:231      评论:0      收藏:0      [点我收藏+]

标签:clu   each   printf   scan   logs   ios   cas   for   读取   

Problem Description

 

Calculate A + B.

 

Input

 

Each line will contain two integers A and B. Process to end of file.

 

Output

 

For each case, output A + B in one line.

 

Sample Input

 

1 1

 

Sample Output

 

2

 

分析

输入两个数A和B,求A+B。

 

但是是多行的,因此需要用循环反复读取。

 

又因为输入数据中没有说有多少行,因此不能使用计数循环,而要通过while循环判断是否到达文件尾,如果是则停止循环。

 

而在循环中则是将输入的两个数的和算出,并输出。

 

因此C/C++代码如下:

 

C

 

#include <stdio.h>
int main()
{
    int a, b;
    while (scanf("%d%d", &a, &b) != EOF)
        printf("%d\n", a + b);
    return 0;
}

 

C++

 

C++和C区别不大,仅仅是<stdio.h>和<iostream>,printf和cout,scanf和cin,以及如何判断EOF。

 

#include <iostream>
int main()
{
    int a, b;
    while (cin >> a >> b)
        cout << (a + b) << endl;
    return 0;
}

 

[HDU1000] A + B Problem

标签:clu   each   printf   scan   logs   ios   cas   for   读取   

原文地址:http://www.cnblogs.com/collectionne/p/6786367.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!