码迷,mamicode.com
首页 > 其他好文 > 详细

洛谷 P2866 [USACO06NOV]糟糕的一天Bad Hair Day

时间:2017-05-01 19:50:12      阅读:221      评论:0      收藏:0      [点我收藏+]

标签:number   line   from   cin   相等   lines   and   rom   输入输出   

 P2866 [USACO06NOV]糟糕的一天Bad Hair DaY

题目描述

Some of Farmer John‘s N cows (1 ≤ N ≤ 80,000) are having a bad hair day! Since each cow is self-conscious about her messy hairstyle, FJ wants to count the number of other cows that can see the top of other cows‘ heads.

Each cow i has a specified height hi (1 ≤ hi ≤ 1,000,000,000) and is standing in a line of cows all facing east (to the right in our diagrams). Therefore, cow i can see the tops of the heads of cows in front of her (namely cows i+1, i+2, and so on), for as long as these cows are strictly shorter than cow i.

Consider this example:

        =

=       =

=   -   =         Cows facing right -->

=   =   =

= - = = =

= = = = = =

1 2 3 4 5 6 Cow#1 can see the hairstyle of cows #2, 3, 4

Cow#2 can see no cow‘s hairstyle

Cow#3 can see the hairstyle of cow #4

Cow#4 can see no cow‘s hairstyle

Cow#5 can see the hairstyle of cow 6

Cow#6 can see no cows at all!

Let ci denote the number of cows whose hairstyle is visible from cow i; please compute the sum of c1 through cN.For this example, the desired is answer 3 + 0 + 1 + 0 + 1 + 0 = 5.

农民约翰的某N(1 < N < 80000)头奶牛正在过乱头发节!由于每头牛都意识到自己凌乱不堪 的发型,约翰希望统计出能够看到其他牛的头发的牛的数量.

每一头牛i有一个高度所有N头牛面向东方排成一排,牛N在最前面,而 牛1在最后面.第i头牛可以看到她前面的那些牛的头,只要那些牛的高度严格小于她的高度,而且 中间没有比hi高或相等的奶牛阻隔.

让N表示第i头牛可以看到发型的牛的数量;请输出Ci的总和

输入输出格式

输入格式:

 

Line 1: The number of cows, N.

Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i.

 

输出格式:

 

Line 1: A single integer that is the sum of c1 through cN.

 

输入输出样例

输入样例#1:
6
10
3
7
4
12
2
输出样例#1:
5
水题,模拟一下栈;
#include<iostream>
#include<cstdio>
#include<cstring>
#define MAXN 80000+15
using namespace std;
long long n,h[MAXN],ans;
long long strck[MAXN],top;
int main(){
    cin>>n;
    for(int i=1;i<=n;i++){
        cin>>h[i];
    }
    h[n+1]=0x7fffffff;
    for(int i=1;i<=n+1;i++){
        while(top&&h[strck[top]]<=h[i]){
            ans+=i-strck[top]-1;
            top--;
        }
        top++;
        strck[top]=i;
    }
    cout<<ans;
}

别忘了开long long 

洛谷 P2866 [USACO06NOV]糟糕的一天Bad Hair Day

标签:number   line   from   cin   相等   lines   and   rom   输入输出   

原文地址:http://www.cnblogs.com/cangT-Tlan/p/6792475.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!