码迷,mamicode.com
首页 > 其他好文 > 详细

Codeforces Round #411 (Div. 2)C. Find Amir(想法题)

时间:2017-05-05 14:11:17      阅读:191      评论:0      收藏:0      [点我收藏+]

标签:number   ash   img   bit   策略   each   std   font   cpp   

传送门

Description

A few years ago Sajjad left his school and register to another one due to security reasons. Now he wishes to find Amir, one of his schoolmates and good friends.

There are n schools numerated from 1 to n. One can travel between each pair of them, to do so, he needs to buy a ticket. The ticker between schools i and j costs 技术分享 and can be used multiple times. Help Sajjad to find the minimum cost he needs to pay for tickets to visit all schools. He can start and finish in any school.

Input

The first line contains a single integer n (1 ≤ n ≤ 105) — the number of schools.

Output

Print single integer: the minimum cost of tickets needed to visit all schools.

Sample Input

2

10

Sample Output

0

4

Note

In the first example we can buy a ticket between the schools that costs 技术分享.

思路

题解:因为从学校 i 到学校 j 花费为 技术分享,因此尽量使1与n搭配,2与n - 1搭配,那么接下来要解决的就是联通这些搭配。从样例我们可以写出如下:

1      2     3     4    5

10    9     8     7    6

那么我们就可以从10到2,9到3,8到4...每次花费为1。按照这种策略可使最后结果最小。

 

#include<bits/stdc++.h>
using namespace std;

int main()
{
	int n;
	scanf("%d",&n);
	if (n % 2 == 0)
	{
		printf("%d\n",n/2-1);
	}
	else	printf("%d\n",n/2);
	return 0;
}

  

 

Codeforces Round #411 (Div. 2)C. Find Amir(想法题)

标签:number   ash   img   bit   策略   each   std   font   cpp   

原文地址:http://www.cnblogs.com/zzy19961112/p/6812476.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!