码迷,mamicode.com
首页 > 编程语言 > 详细

算法笔记_181:历届试题 回文数字(Java)

时间:2017-05-05 21:49:25      阅读:124      评论:0      收藏:0      [点我收藏+]

标签:没有   com   ons   目录   笔记   技术分享   数位   color   logs   

目录

1 问题描述

2 解决方案

 


1 问题描述

问题描述
  观察数字:12321,123321 都有一个共同的特征,无论从左到右读还是从右向左读,都是相同的。这样的数字叫做:回文数字。

  本题要求你找到一些5位或6位的十进制数字。满足如下要求:
  该数字的各个数位之和等于输入的整数。
输入格式
  一个正整数 n (10<n<100), 表示要求满足的数位和。
输出格式
  若干行,每行包含一个满足要求的5位或6位整数。
  数字按从小到大的顺序排列。
  如果没有满足条件的,输出:-1
样例输入
44
样例输出
99899
499994
589985
598895
679976
688886
697796
769967
778877
787787
796697
859958
868868
877778
886688
895598
949949
958859
967769
976679
985589
994499
样例输入
60
样例输出
-1

 

 

 


2 解决方案

技术分享

 

具体代码如下:

 

import java.util.ArrayList;
import java.util.Collections;
import java.util.Scanner;

public class Main {
    public static int n;
    
    public void getResult() {
        ArrayList<Integer> result = new ArrayList<Integer>();
        for(int i = 10000;i < 1000000;i++) {
            String temp = i + "";
            if(temp.length() == 5) {
                if(temp.charAt(0) == temp.charAt(4) && temp.charAt(1)
                        == temp.charAt(3)) {
                    int num = i % 10 * 2 + i / 10 % 10 * 2 + i / 100 % 10;
                    if(num == n)
                        result.add(i);
                }
            } else if(temp.length() == 6) {
                if(temp.charAt(0) == temp.charAt(5) && temp.charAt(1)
                        == temp.charAt(4) && temp.charAt(2) == temp.charAt(3)) {
                    int num = i % 10 * 2 + i / 10 % 10 * 2 + i / 100 % 10 * 2;
                    if(num == n)
                        result.add(i);
                }
            }
        }
        if(result.size() == 0)
            System.out.println("-1");
        else {
            Collections.sort(result);
            for(int i = 0;i < result.size();i++)
                System.out.println(result.get(i));
        }
    }
        
    public static void main(String[] args) {
        Main test = new Main();
        Scanner in = new Scanner(System.in);
        n = in.nextInt();
        test.getResult();
    }
}

 

 

 

 

 

算法笔记_181:历届试题 回文数字(Java)

标签:没有   com   ons   目录   笔记   技术分享   数位   color   logs   

原文地址:http://www.cnblogs.com/liuzhen1995/p/6814900.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!