码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 2076 夹角有多大(题目已修改,注意读题)

时间:2017-05-10 14:47:35      阅读:153      评论:0      收藏:0      [点我收藏+]

标签:abs   substring   tin   orm   final   man   ann   input   整数   

Problem Description
时间过的好快,一个学期就这么的过去了,xhd在傻傻的看着表,出于对数据的渴望,突然他想知道这个表的时针和分针的夹角是多少。现在xhd知道的只有时间,请你帮他算出这个夹角。

注:夹角的范围[0,180],时针和分针的转动是连续而不是离散的。
 

 

Input
输入数据的第一行是一个数据T,表示有T组数据。
每组数据有三个整数h(0 <= h < 24),m(0 <= m < 60),s(0 <= s < 60)分别表示时、分、秒。
 

 

Output
对于每组输入数据,输出夹角的大小的整数部分。
 

 

Sample Input
2 8 3 17 5 13 30
 

 

Sample Output
138 75

 分析:注意小时数是0~24,不是石英表盘时针数,两个公式就能解决

时针度数(从12点为0度开始):hAngle=30*h + 1.0/2*m + 1.0/120*s;

分针度数(从12点为0度开始):mAngle=6*m + 1.0/10*s;

约分我采用的是截取字符串中的子串。也可以用向下取整约分。

import java.math.BigDecimal;
import java.math.RoundingMode;
import java.util.Scanner;

public class Main{
//    public final static double pi = 3.1415927;
    public static void main(String[] args) {
        
        Scanner sin=new Scanner(System.in);
        int t = sin.nextInt();
        for(int i=0; i<t; i++){
            int h = sin.nextInt();
            if(h>12) h -= 12;
            int m = sin.nextInt();
            int s = sin.nextInt();
            double hAngle = 30*h + 1.0/2*m + 1.0/120*s;
            double mAngle = 6*m + 1.0/10*s;
            double result = Math.abs(hAngle-mAngle);
            if(result > 180){
                result = 360 - result;
            }
            
            String res = String.format("%.3f", result);
//            System.out.println(res);
            int loc = res.indexOf(".");
            String st = res.substring(0,loc);
            System.out.println(st);
//            System.out.println(res);
//            int num = new BigDecimal(result).setScale(0, RoundingMode.DOWN).intValue();
//            System.out.println(num);
        }
    }
}

 

HDU 2076 夹角有多大(题目已修改,注意读题)

标签:abs   substring   tin   orm   final   man   ann   input   整数   

原文地址:http://www.cnblogs.com/hey-man/p/6835354.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!