码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2456 Aggressive cows (二分 基础)

时间:2017-05-11 11:47:18      阅读:160      评论:0      收藏:0      [点我收藏+]

标签:ssi   tar   blank   john   pre   ++   from   org   search   


Aggressive cows
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 7924   Accepted: 3959

Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don‘t like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

* Line 1: Two space-separated integers: N and C

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output

* Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

Hint

OUTPUT DETAILS:

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.

Huge input data,scanf is recommended.

Source

USACO 2005 February Gold

题目链接:http://poj.org/problem?

id=2456

题目大意:一个数轴上n个点,每一个点一个整数值,有c个物品。要放在这些点的某几个上,求怎么放能够使随意两个物品间距离的最小值最大,求这个最大值

题目分析:最小值最大,典型二分题。二分距离的值推断

#include <cstdio>
#include <algorithm>
using namespace std;
int const INF = 0x3fffffff;
int const MAX = 1e5 + 5;
int d[MAX];
int n, c;

int cal(int m)
{	
	int ans = 0, now = d[0];
	for(int i = 1; i < n; )
	{
		while(d[i] < now + m)
			i ++;
		ans ++;
		now = d[i];
	}
	return ans;
}	

int main()
{
	scanf("%d %d", &n, &c);
	for(int i = 0; i < n; i++)
		scanf("%d", &d[i]);
	sort(d, d + n);
	int r = d[n - 1] - d[0], l = 0, ans = 0;
	while(l <= r)
	{
		int m = (l + r) / 2;
		int num = cal(m);
		if(num >= c)
		{
			ans = m;
			l = m + 1;
		}
		else
			r = m - 1;
	}
	printf("%d\n", ans);
}


POJ 2456 Aggressive cows (二分 基础)

标签:ssi   tar   blank   john   pre   ++   from   org   search   

原文地址:http://www.cnblogs.com/slgkaifa/p/6839781.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!