码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 2225 Asteroids!(三维BFS)

时间:2014-08-26 15:37:16      阅读:292      评论:0      收藏:0      [点我收藏+]

标签:hdu   三维   bfs   



Asteroids!
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

You‘re in space. 
You want to get home. 
There are asteroids. 
You don‘t want to hit them. 
 

Input

Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets. 

A single data set has 5 components: 

Start line - A single line, "START N", where 1 <= N <= 10. 

Slice list - A series of N slices. Each slice is an N x N matrix representing a horizontal slice through the asteroid field. Each position in the matrix will be one of two values: 

‘O‘ - (the letter "oh") Empty space 

‘X‘ - (upper-case) Asteroid present 

Starting Position - A single line, "A B C", denoting the <A,B,C> coordinates of your craft‘s starting position. The coordinate values will be integers separated by individual spaces. 

Target Position - A single line, "D E F", denoting the <D,E,F> coordinates of your target‘s position. The coordinate values will be integers separated by individual spaces. 

End line - A single line, "END" 

The origin of the coordinate system is <0,0,0>. Therefore, each component of each coordinate vector will be an integer between 0 and N-1, inclusive. 

The first coordinate in a set indicates the column. Left column = 0. 

The second coordinate in a set indicates the row. Top row = 0. 

The third coordinate in a set indicates the slice. First slice = 0. 

Both the Starting Position and the Target Position will be in empty space. 

 

Output

For each data set, there will be exactly one output set, and there will be no blank lines separating output sets. 

A single output set consists of a single line. If a route exists, the line will be in the format "X Y", where X is the same as N from the corresponding input data set and Y is the least number of moves necessary to get your ship from the starting position to the target position. If there is no route from the starting position to the target position, the line will be "NO ROUTE" instead. 

A move can only be in one of the six basic directions: up, down, left, right, forward, back. Phrased more precisely, a move will either increment or decrement a single component of your current position vector by 1. 

 

Sample Input

START 1 O 0 0 0 0 0 0 END START 3 XXX XXX XXX OOO OOO OOO XXX XXX XXX 0 0 1 2 2 1 END START 5 OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO XXXXX XXXXX XXXXX XXXXX XXXXX OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO 0 0 0 4 4 4 END
 

Sample Output

1 0 3 4 NO ROUTE
 

题目大意:

X代表墙,不能走,如果可以走出来,输出步数,否则,输出“NO ROUTE”。

解题思路:

三维BFS,把跳跃看成是三维坐标Z的上下跳动。


代码:

#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<queue>
#define N 15
using namespace std;

struct node{
    int i,j,k;
    node(int i0=0,int j0=0,int k0=0){
        i=i0;j=j0;k=k0;
    }
};

int directionJ[6]={1,0,-1, 0,0, 0},ie,je,ke;
int directionI[6]={0,1, 0,-1,0, 0},step[N][N][N];
int directionK[6]={0,0, 0, 0,1,-1},n;
bool ans;
string str[N*N][N];
queue <node> path;

void bfs(node s){
    if(s.i==ie&&s.j==je&&s.k==ke) {ans=true;return;}
    for(int i=0;i<6;i++){
        int di=s.i+directionI[i],dj=s.j+directionJ[i],dk=s.k+directionK[i];
        if(di>=0&&di<n&&dj>=0&&dj<n&&dk>=0&&dk<n){
            if(str[dk][di][dj]!='X'&&step[dk][di][dj]==-1){
                path.push(node(di,dj,dk));
                step[dk][di][dj]=step[s.k][s.i][s.j]+1;
            }
        }
    }
    if(!path.empty())  path.pop();
    if(path.empty())  return;
    bfs(path.front());
}

int main(){
    char tmpstr[10];
    while(scanf("%s%d",tmpstr,&n)!=EOF){
        int is,js,ks;
        ans=false;
        memset(step,-1,sizeof(step));
        while(!path.empty()) path.pop();
        for(int k=0;k<n;k++){
            for(int i=0;i<n;i++){
                    cin>>str[k][i];
            }
        }
        scanf("%d%d%d%d%d%d\n%s",&is,&js,&ks,&ie,&je,&ke,tmpstr);
        path.push(node(is,js,ks));
        step[ks][is][js]=0;
        bfs(path.front());
        if(!ans) printf("NO ROUTE\n");
        else printf("%d %d\n",n,step[ke][ie][je]);
    }
    return 0;
}



HDU 2225 Asteroids!(三维BFS)

标签:hdu   三维   bfs   

原文地址:http://blog.csdn.net/hush_lei/article/details/38846725

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!