码迷,mamicode.com
首页 > 其他好文 > 详细

POJ Layout

时间:2014-08-26 16:55:26      阅读:220      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   os   io   strong   for   

A - Layout
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate).

Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated.

Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.

Input

Line 1: Three space-separated integers: N, ML, and MD.

Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart.

Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.

Output

Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.

Sample Input

4 2 1
1 3 10
2 4 20
2 3 3

Sample Output

27

Hint

Explanation of the sample:

There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart.

The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.
 
 
算法分析:
      不知道为什么用SPFA 会超时,改成bellman_ford 算法了就行了,并且需要注意 差分约束 建图时 两个点是否眼交换!
   二题目里却说是有大小顺序的,但是不交换顺序就错了!(我用位运算交换顺序,据说会节省时间,但是刘汝佳的树立却说不建议这样写,不知道为什    么?)
 
 
 
Accepted:
 
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#define INF 9999999

int dis[1010];
int cnt;
int n, ml, md;

struct N
{
    int u;
    int v;
    int w;
}s[200005];

void add(int u, int v, int w )
{
    s[cnt].u=u;
    s[cnt].v=v;
    s[cnt++].w=w;
}

void bellman_ford()
{
    int i, j;
    for(i=1; i<=n; i++)
       dis[i]=INF;
    dis[1]=0;

    for(i=2; i<=n; i++ )
    {
        int flag=0;
        for(j=0; j<cnt; j++ ) //检查每条边
        {
            if( dis[s[j].v] > dis[s[j].u] + s[j].w )
            {
                dis[s[j].v] = dis[s[j].u]+s[j].w ;
                flag=1;
            }
        }
        if(flag==0)
        break;
    }
     for(i=0; i<cnt; i++)
    {
        if(dis[s[i].v] > dis[s[i].u]+s[i].w )
            break;
    }
    if(i<cnt)
        printf("-1\n");
    else
    {
        if( dis[n]==INF )
        printf("-2\n");
        else
        printf("%d\n", dis[n] );
    }
}

int main()
{
    int i, j;
    int u, v, w;
    while(scanf("%d %d %d", &n, &ml, &md)!=EOF)
    {
        cnt=0;
        for(i=0; i<ml; i++)
        {
            scanf("%d %d %d", &u, &v, &w ); //亲密的牛  最大距离
            if(u>v)
            {
                u=u^v; v=v^u; u=u^v;    //还可以这样写: u^=v^=u^=v ;
            }
            add(u, v, w);
        }
        for(j=0; j<md; j++)
        {
            scanf("%d %d %d", &u, &v, &w ); //排斥的牛  最小距离
            if(u<v)
            {
                u=u^v; v=v^u; u=u^v;   //  u^=v^=u^=v ;
            }
            add(u, v, -w);
        }
        bellman_ford();
    }
    return 0;
}

 

POJ Layout

标签:des   style   blog   http   color   os   io   strong   for   

原文地址:http://www.cnblogs.com/yspworld/p/3937414.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!