码迷,mamicode.com
首页 > 其他好文 > 详细

ZOJ 1584:Sunny Cup 2003 - Preliminary Round(最小生成树&&prim)

时间:2014-08-26 22:45:56      阅读:308      评论:0      收藏:0      [点我收藏+]

标签:style   http   os   io   strong   for   ar   数据   art   

Sunny Cup 2003 - Preliminary Round

April 20th, 12:00 - 17:00

Problem E: QS Network


In the planet w-503 of galaxy cgb, there is a kind of intelligent creature named QS. QScommunicate with each other via networks. If two QS want to get connected, they need to buy two network adapters (one for each QS) and a segment of network cable. Please be advised that ONE NETWORK ADAPTER CAN ONLY BE USED IN A SINGLE CONNECTION.(ie. if a QS want to setup four connections, it needs to buy four adapters). In the procedure of communication, a QS broadcasts its message to all the QS it is connected with, the group of QS who receive the message broadcast the message to all the QS they connected with, the procedure repeats until all the QS‘s have received the message.

A sample is shown below:

bubuko.com,布布扣


A sample QS network, and QS A want to send a message.

Step 1. QS A sends message to QS B and QS C;

Step 2. QS B sends message to QS A ; QS C sends message to QS A and QS D;

Step 3. the procedure terminates because all the QS received the message.

Each QS has its favorate brand of network adapters and always buys the brand in all of its connections. Also the distance between QS vary. Given the price of each QS‘s favorate brand of network adapters and the price of cable between each pair of QS, your task is to write a program to determine the minimum cost to setup a QS network.


Input

The 1st line of the input contains an integer t which indicates the number of data sets.

From the second line there are t data sets.

In a single data set,the 1st line contains an interger n which indicates the number of QS.

The 2nd line contains n integers, indicating the price of each QS‘s favorate network adapter.

In the 3rd line to the n+2th line contain a matrix indicating the price of cable between ecah pair of QS.

Constrains:

all the integers in the input are non-negative and not more than 1000.


Output

for each data set,output the minimum cost in a line. NO extra empty lines needed.


Sample Input

1
3
10 20 30
0 100 200
100 0 300
200 300 0


Sample Output

370


#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<vector>
#include<queue>
#include<cmath>
#define MAXN 1005
#define INF 0x1f1f1f1f

using namespace std;

using namespace std;

int n, ans, cas;      //QS适配器的个数,结果,測试数据组数;
int lowcost[MAXN];    //充当Prim算法中的两个数组lowcost和nearvex的作用;
int adapt[MAXN];    //每一个QS喜欢的适配器的价格;
int Edge[MAXN][MAXN];  //邻接矩阵;

void Init()
{
    scanf("%d", &n);
    for(int i=0; i<n; i++) scanf("%d", &adapt[i]);   //输入价格;
    for(int i=0; i<n; i++)
    {
        for(int j=0; j<n; j++)      //邻接矩阵初始化;
        {
            scanf("%d", &Edge[i][j]);
            if(i == j) Edge[i][j] = INF;
            else Edge[i][j] += (adapt[i]+adapt[j]);
        }
    }
    memset( lowcost, 0, sizeof(lowcost) );
    ans = 0;
}

void Prim()    //Prim算法核心;
{
    lowcost[0] = -1;    //从顶点0開始构造最小生成树;
    for(int i=1; i<n; i++) lowcost[i] = Edge[0][i];
    for(int i=1; i<n; i++)       //把其它n-1个顶点扩展到生成树其中;
    {
        int min = INF, k;
        for(int j=0; j<n; j++)      //找到当前可用的权值最小的边;
        {
            if(lowcost[j] != -1 && lowcost[j] < min)
            {
                k = j;
                min = lowcost[j];
            }
        }
        ans += min;
        lowcost[k] = -1;    //把顶点k扩展进来;
        for(int i=0; i<n; i++) if(Edge[k][i] < lowcost[i])
            {
                lowcost[i] = Edge[k][i];
            }
    }
    printf("%d\n", ans);
}

int main()
{
    scanf("%d", &cas);
    while(cas--)
    {
        Init();
        Prim();
    }
    return 0;
}









ZOJ 1584:Sunny Cup 2003 - Preliminary Round(最小生成树&amp;&amp;prim)

标签:style   http   os   io   strong   for   ar   数据   art   

原文地址:http://www.cnblogs.com/mengfanrong/p/3938245.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!