码迷,mamicode.com
首页 > 其他好文 > 详细

贪心 poj2586

时间:2014-08-28 13:00:29      阅读:191      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   os   使用   io   strong   

Y2K Accounting Bug
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 10537   Accepted: 5264

Description

Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc. 
All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite. 

Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.

Input

Input is a sequence of lines, each containing two positive integers s and d.

Output

For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.

Sample Input

59 237
375 743
200000 849694
2500000 8000000

Sample Output

116
28
300612
Deficit
题目意思:MS公司在1999年每个月有盈余有亏损,现在只知道盈余一定为s,亏损一定为d,并且该公司每连续五个月的总利润都是亏损(0-4,1-5,...7-11)(编号0-11),问如何取值(s,-d)在该条件下使得总利润最大,并且询问总利润是否可能为正数(盈利)
思路:贪心,一开始是统计需要次数最多的那个点,但是那样容易造成断层,(比如第二组数据375 473,5 6 7 8都是被需要次数相同的,这个算法就不知道该先选择哪个,可能会先选择5,6,而4是一定要选的,选了4就不用选6了)
改变贪心思路,初始化全部选s,从头往尾扫,每个sum都必须变成-的为止,那么选择最右边的大于0,因为左边的要不就已经变成-的,或者使用次数没有右边多,直到sum变成负数为止
bubuko.com,布布扣
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int s,d;
int a[12];
long long sum[8];
int main()
{
    while(scanf("%d%d",&s,&d)==2){
        for(int i=0;i<11;i++)a[i]=s;
        for(int i=0;i<8;i++)sum[i]=5*s;
        for(int i=0;i<8;i++){
                int t=4;
                while(sum[i]>=0){
                    a[i+t]=-d;
                    for(int j=max(i+t-4,0);j<8&&j<=i+t;j++){
                        sum[j]-=d+s;
                    }
                    t--;
                }
        }
        long long ans=sum[0]+sum[7]+a[5]+a[6];
        if(ans>=0)printf("%I64d\n",ans);
        else printf("Deficit\n");
    }
    return 0;
}
View Code

 

贪心 poj2586

标签:des   style   blog   http   color   os   使用   io   strong   

原文地址:http://www.cnblogs.com/xuesu/p/3941288.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!