码迷,mamicode.com
首页 > 其他好文 > 详细

[2012山东省第三届ACM大学生程序设计竞赛]——Fruit Ninja II

时间:2014-04-27 18:03:25      阅读:653      评论:0      收藏:0      [点我收藏+]

标签:2012山东省第三届acm大学生程序设计   fruit ninja ii   山东省赛   sdut2416   

Fruit Ninja II

题目:http://acm.sdut.edu.cn/sdutoj/problem.php?action=showproblem&problemid=2416

Time Limit: 5000ms Memory limit: 65536K 有疑问?点这里^_^


题目描述

bubuko.com,布布扣
Have you ever played a popular game named "Fruit Ninja"?

Fruit Ninja (known as Fruit Ninja HD on the iPad and Fruit Ninja THD for Nvidia Tegra 2 based Android devices) is a video game developed by Halfbrick. It was released April 21, 2010 for iPod Touch and iPhone devices, July 12, 2010 for the iPad, September 17, 2010 for Android OS devices. Fruit Ninja was well received by critics and consumers. The iOS version sold over 200,000 copies in its first month. By March 2011 total downloads across all platforms exceeded 20 million. It was also named one of Time magazine‘s 50 Best iPhone Apps of 2011.
bubuko.com,布布扣
"Swipe your finger across the screen to deliciously slash and splatter fruit like a true ninja warrior. Be careful of bombs - they are explosive to touch and will put a swift end to your juicy adventure!" - As it described on http://www.fruitninja.com/, in Fruit Ninja the player slices fruit with a blade controlled via a touch pad. As the fruit is thrown onto the screen, the player swipes their finger across the screen to create a slicing motion, attempting to slice the fruit in parts. Extra points are awarded for slicing multiple fruits with one swipe, and players can use additional fingers to make multiple slices simultaneously. Players must slice all fruit; if three pieces of fruit are missed the game ends. Bombs are occasionally thrown onto the screen, and will also end the game should the player slice them.

Maybe you are an excellent player of Fruit Ninja, but in this problem we focus on something more mathematically. Consider a certain slicing trace you create on the touch pad, you slice a fruit (an apple or a banana or something else) into two parts at once. Can you figure out the volume of each part?
bubuko.com,布布扣




Impossible task? Let us do some simplification by define our own Fruit Ninja game.
In our new Fruit Ninja game, only one kind of fruit will be thrown into the air - watermelon. What‘s more, the shape of every watermelon is a special Ellipsoid (details reachable at http://en.wikipedia.org/wiki/Ellipsoid) that it‘s polar radius OC is always equals to it‘s equatorial radius OB. Formally, we can get this kind of solid by revolving a certain ellipse on the x-axis. And the slicing trace the player created (represented as MN in Illustration III) is a line parallel to the x-axis. The slicing motion slice the watermelon into two parts, and the section (shown as the dark part in Illustration III) is parallel to plane x-O-y.

Given the length of OA, OB, OM (OM is the distance between the section and plane x-O-y), your task is to figure out the volume of the bigger part.


输入
There are multiple test cases. First line is an integer T (T ≈ 100), indicating the number of test cases.

For each test case, there are three integers: a, b, H, corresponding the length of OA, OB, OM. You may suppose that 0 < b <= a <= 100 and 0 <= H <= 100.

输出
Output case number "Case %d: " followed by a floating point number (round to 3) for each test case.

示例输入

4
2 2 0
2 2 1
2 2 2

2 2 3


示例输出
Case 1: 16.755
Case 2: 28.274
Case 3: 33.510

Case 4: 33.510


提示
In case 4, H is larger than b, which simply represent a miss.
http://www.fruitninja.com/
http://en.wikipedia.org/wiki/Fruit_Ninja
http://en.wikipedia.org/wiki/Ellipsoid

来源

2012年"浪潮杯"山东省第三届ACM大学生程序设计竞赛


水果忍者!

恩,就是切水果的小游戏。

给你一个椭圆形,它的OB与OC是相等的。。。

然后给你一个H,距离椭圆形中心的位置OH,刀切在这个平面上,

计算切完后,体积较大的部分的体积。

或许刚看到题,觉得是计算几何。

但是,这是解析几何,甚至就是完完全全高数题啊o(╯□╰)o

高数书上的例题,有木有。。。

三重积分的说。。。


就是这样,恩。


#include <iostream>  
#include<stdio.h>  
using namespace std;  
const double PI =  3.1415926535898;  
int main()  
{  
    int t,count = 1;;  
    double a,b,h,V;  
    scanf("%d",&t);  
    while(t--)  
    {  
        scanf("%lf%lf%lf",&a,&b,&h);  
        if(h>=b)  
            h = b;  
        V = 2.0/3.0*PI*a*b*b+PI*a*b*h-PI*a*h*h*h/(3.0*b);  
        printf("Case %d: ",count++);  
        printf("%.3lf\n",V);  
    }  
    return 0;  
}  


[2012山东省第三届ACM大学生程序设计竞赛]——Fruit Ninja II,布布扣,bubuko.com

[2012山东省第三届ACM大学生程序设计竞赛]——Fruit Ninja II

标签:2012山东省第三届acm大学生程序设计   fruit ninja ii   山东省赛   sdut2416   

原文地址:http://blog.csdn.net/lttree/article/details/24591011

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!