码迷,mamicode.com
首页 > 其他好文 > 详细

1084. Broken Keyboard (20)

时间:2017-06-12 13:10:49      阅读:164      评论:0      收藏:0      [点我收藏+]

标签:sof   specific   pad   margin   ann   family   stream   oar   namespace   

题目例如以下:

On a broken keyboard, some of the keys are worn out. So when you type some sentences, the characters corresponding to those keys will not appear on screen.

Now given a string that you are supposed to type, and the string that you actually type out, please list those keys which are for sure worn out.

Input Specification:

Each input file contains one test case. For each case, the 1st line contains the original string, and the 2nd line contains the typed-out string. Each string contains no more than 80 characters which are either English letters [A-Z] (case insensitive), digital numbers [0-9], or "_" (representing the space). It is guaranteed that both strings are non-empty.

Output Specification:

For each test case, print in one line the keys that are worn out, in the order of being detected. The English letters must be capitalized. Each worn out key must be printed once only. It is guaranteed that there is at least one worn out key.

Sample Input:
7_This_is_a_test
_hs_s_a_es
Sample Output:
7TI



题目的实质就是从A字符串中找到全部B中没有的。然后输出。注意要把字母转为大写,而且反复的仅仅输出一次。输出顺序为与从前到后探測到的顺序同样。

由于不区分大写和小写,所以我们使用一个map存储全部实际输出的字符,然后遍历期望的字符串,假设遍历到的字符是字母,先转为大写,然后去map查询,假设查不到则说明是要输出的。而且存储map,这样就保证了不反复输出,也满足了输出顺序和大写。

代码例如以下:

#include <iostream>
#include <string>
#include <map>
#include <stdio.h>

using namespace std;

int main()
{
    string wanner,input;
    cin >> wanner >> input;
    map<char,bool> inputMap;
    for(int i = 0; i < input.length(); i++){
        input[i] = isalpha(input[i]) ? toupper(input[i]) : input[i];
        inputMap[input[i]] = true;
    }
    for(int i = 0; i < wanner.length(); i++){
        char c = wanner[i];
        c = isalpha(c) ? toupper(c) : c;
        if(inputMap.find(c) == inputMap.end()){
            inputMap[c] = true;
            printf("%c",c);
        }
    }
    return 0;
}

1084. Broken Keyboard (20)

标签:sof   specific   pad   margin   ann   family   stream   oar   namespace   

原文地址:http://www.cnblogs.com/cxchanpin/p/6991999.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!