码迷,mamicode.com
首页 > 其他好文 > 详细

nyoj 714 Card Trick

时间:2017-06-20 10:51:31      阅读:198      评论:0      收藏:0      [点我收藏+]

标签:i++   ber   from   ack   otto   follow   hold   one   his   

Card Trick

时间限制:1000 ms  |  内存限制:65535 KB

难度:3

描述

The magician shuffles a small pack of cards, holds it face down and performs the following procedure:

  1. The top card is moved to the bottom of the pack. The new top card is dealt face up onto the table. It is the Ace of Spades.
  2. Two cards are moved one at a time from the top to the bottom. The next card is dealt face up onto the table. It is the Two of Spades.
  3. Three cards are moved one at a time…
  4. This goes on until the nth and last card turns out to be the n of Spades.

This impressive trick works if the magician knows how to arrange the cards beforehand (and knows how to give a false shuffle). Your program has to determine the initial order of the cards for a given number of cards, 1 ≤ n ≤ 13.

输入

On the first line of the input is a single positive integer k, telling the number of test cases to follow. 1 ≤ k ≤ 10 Each case consists of one line containing the integer n. 1 ≤ n ≤ 13

输出

For each test case, output a line with the correct permutation of the values 1 to n, space separated. The first number showing the top card of the pack, etc…

样例输入

2

4

5

样例输出

2 1 4 3

3 1 4 5 2

#include<cstdio>
#include<cstring>

int a[15][15]={{1},{2,1},{3,1,2},{2,1,4,3},{3,1,4,5,2},{4,1,6,3,2,5},{5,1,3,4,2,6,7},{3,1,7,5,2,6,8,4},{7,1,8,6,2,9,4,5,3},
			{9,1,8,5,2,4,7,6,3,10},{5,1,6,4,2,10,11,7,3,8,9},{7,1,4,9,2,11,10,8,3,6,5,12},{4,1,13,11,2,10,6,7,3,5,12,9,8}};

int main()
{
	int t,n;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		for(int i=0;i<n;i++)
			printf("%d ",a[n-1][i]);
		printf("\n");
	}
	return 0;
}           

  

nyoj 714 Card Trick

标签:i++   ber   from   ack   otto   follow   hold   one   his   

原文地址:http://www.cnblogs.com/zhangliu/p/7052991.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!