码迷,mamicode.com
首页 > 其他好文 > 详细

Hdu 1718 Rank

时间:2017-06-21 11:53:14      阅读:119      评论:0      收藏:0      [点我收藏+]

标签:uniq   top   can   case   mis   integer   lines   ring   inpu   

Rank

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5525    Accepted Submission(s): 2201

Problem Description

Jackson wants to know his rank in the class. The professor has posted a list of student numbers and marks. Compute Jackson’s rank in class; that is, if he has the top mark(or is tied for the top mark) his rank is 1; if he has the second best mark(or is tied) his rank is 2, and so on.

 

 

Input

The input consist of several test cases. Each case begins with the student number of Jackson, an integer between 10000000 and 99999999. Following the student number are several lines, each containing a student number between 10000000 and 99999999 and a mark between 0 and 100. A line with a student number and mark of 0 terminates each test case. There are no more than 1000 students in the class, and each has a unique student number.

 

 

Output

For each test case, output a line giving Jackson’s rank in the class.

 

 

Sample Input

20070101

20070102 100

20070101 33

20070103 22

20070106 33

0 0

 

 

Sample Output

2

#include <stdio.h>
#include <string.h>    
int main()
    {
        int sn, s[1000], tsn, m, range, score, i, j;
        while (scanf("%d", &sn)!=EOF)
        {
            range = 1;
            i = 0;
            while(scanf("%d%d", &tsn, &m), tsn||m)//当两个都为0时不进入循环            {
                if(tsn == sn)
                    score = m;
                s[i++] = m;
            }
            for (j = 0; j < i; j++)
                if(s[j] > score)
                    range++;
            printf("%d\n", range);
        }
        return 0;
}

  

Hdu 1718 Rank

标签:uniq   top   can   case   mis   integer   lines   ring   inpu   

原文地址:http://www.cnblogs.com/zhangliu/p/7058031.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!