码迷,mamicode.com
首页 > 其他好文 > 详细

codevs1230 元素查找

时间:2017-06-22 19:10:36      阅读:188      评论:0      收藏:0      [点我收藏+]

标签:main   name   --   can   sample   查找   inpu   body   print   

题目描述 Description

给出n个正整数,然后有m个询问,每个询问一个整数,询问该整数是否在n个正整数中出现过。

输入描述 Input Description

第一行两个整数 n 和m。

第二行n个正整数(1<=n<= 100000)

第三行m个整数(1<=m<=100000)

输出描述 Output Description

一共m行,若出现则输出YES,否则输出NO

样例输入 Sample Input

4 2

2 1 3 4

1 9

样例输出 Sample Output

YES

NO

数据范围及提示 Data Size & Hint

所有数据都不超过10^8

 

//钻石的题目???

 

#include<bits/stdc++.h>
using namespace std;
int n,m;
bool f[100010];

int main(){
	scanf("%d%d",&n,&m);
	while(n--){
		int x;
		scanf("%d",&x);
		f[x]=true;
	}
	while(m--){
		int x;
		scanf("%d",&x);
		if(f[x])printf("YES\n");
		else printf("NO\n");
	}
	return 0;
}


codevs1230 元素查找

标签:main   name   --   can   sample   查找   inpu   body   print   

原文地址:http://www.cnblogs.com/codetogether/p/7066703.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!