码迷,mamicode.com
首页 > 移动开发 > 详细

POJ 题目3321 Apple Tree(线段树)

时间:2017-07-07 21:31:02      阅读:243      评论:0      收藏:0      [点我收藏+]

标签:each   arch   int   car   lin   img   images   iss   bsp   

Apple Tree
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 21566   Accepted: 6548

Description

There is an apple tree outside of kaka‘s house. Every autumn, a lot of apples will grow in the tree. Kaka likes apple very much, so he has been carefully nurturing the big apple tree.

The tree has N forks which are connected by branches. Kaka numbers the forks by 1 toN and the root is always numbered by 1. Apples will grow on the forks and two apple won‘t grow on the same fork. kaka wants to know how many apples are there in a sub-tree, for his study of the produce ability of the apple tree.

The trouble is that a new apple may grow on an empty fork some time and kaka may pick an apple from the tree for his dessert. Can you help kaka?

技术分享

Input

The first line contains an integer N (N ≤ 100,000) , which is the number of the forks in the tree.
The following N - 1 lines each contain two integers u and v, which means forku and fork v are connected by a branch.
The next line contains an integer M (M ≤ 100,000).
The following M lines each contain a message which is either
"C x" which means the existence of the apple on fork x has been changed. i.e. if there is an apple on the fork, then Kaka pick it; otherwise a new apple has grown on the empty fork.
or
"Q x" which means an inquiry for the number of apples in the sub-tree above the forkx, including the apple (if exists) on the fork x
Note the tree is full of apples at the beginning

Output

For every inquiry, output the correspond answer per line.

Sample Input

3
1 2
1 3
3
Q 1
C 2
Q 1

Sample Output

3
2

Source

POJ Monthly--2007.08.05, Huang, Jinsong

题目大意给你一棵树,每一个节点開始的时候有一个苹果,下边m个操作,Q a,查询以a和a的子树的总共的苹果数,c b。改动操作,改变b节点,,開始在有变没有,没有变成有

ac代码

#include<stdio.h>
#include<string.h>
struct node
{
	int u,v,next;
}edge[100010<<1];
int head[100010],cnt,num[100010],son[100010],cc,vis[100100];
void add(int u,int v)
{
	edge[cnt].u=u;
	edge[cnt].v=v;
	edge[cnt].next=head[u];
	head[u]=cnt++;
}
void dfs(int u)
{
	num[u]=++cc;
	//son[u]=1;
	vis[u]=1;
	for(int i=head[u];i!=-1;i=edge[i].next)
	{
		int v=edge[i].v;
		if(!vis[v])
			dfs(v);
	//	son[u]+=son[v];
	}
	son[u]=cc;
}
struct s
{
	int sum,cover;
}node[100010<<2];
void pushdown(int tr,int m)
{
	if(node[tr].cover)
	{
		node[tr<<1].cover=node[tr<<1|1].cover=1;
		node[tr<<1].sum=m-(m>>1);
		node[tr<<1|1].sum=(m>>1);
		node[tr].cover=0;
	}
}
void build(int l,int r,int tr)
{
	node[tr].cover=1;
	node[tr].sum=r-l+1;
	if(l==r)
	{
		return;
	}
	int mid=(l+r)>>1;
	build(l,mid,tr<<1);
	build(mid+1,r,tr<<1|1);
}
void update(int pos,int l,int r,int tr)
{
	if(l==pos&&r==pos)
	{
		if(node[tr].cover)
		{
			node[tr].cover=0;
			node[tr].sum=0;
		}
		else
		{
			node[tr].cover=1;
			node[tr].sum=1;
		}
		return;
	}
	pushdown(tr,r-l+1);
	int mid=(l+r)>>1;
	if(pos<=mid)
		update(pos,l,mid,tr<<1);
	else
		update(pos,mid+1,r,tr<<1|1);
	node[tr].sum=node[tr<<1].sum+node[tr<<1|1].sum;
	if(node[tr<<1].cover&&node[tr<<1|1].cover)
	{
		node[tr].cover=1;
	}
}
int query(int L,int R,int l,int r,int tr)
{
	if(L<=l&&R>=r)
	{
		return node[tr].sum;
	}
	int mid=(l+r)>>1;
	pushdown(tr,r-l+1);
	int ans=0;
	if(L<=mid)
		ans+=query(L,R,l,mid,tr<<1);
	if(R>mid)
		ans+=query(L,R,mid+1,r,tr<<1|1);
	return ans;
	/*if(R<=mid)
		return query(L,R,l,mid,tr<<1);
	else
		if(L>mid)
			return query(L,R,mid+1,r,tr<<1|1);
		else
			return query(L,mid,l,mid,tr<<1)+query(mid+1,R,mid+1,r,tr<<1|1);*/
}
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		cnt=0;
		cc=0;
		memset(head,-1,sizeof(head));
		memset(vis,0,sizeof(vis));
		int i;
		for(i=0;i<n-1;i++)
		{
			int a,b;
			scanf("%d%d",&a,&b);
			add(a,b);
		}
		dfs(1);
		int m;
		scanf("%d",&m);
		build(1,n,1);
		while(m--)
		{
			char s[2];
			scanf("%s",s);
			if(s[0]=='Q')
			{
				int a;
				scanf("%d",&a);
				int ans=query(num[a],son[a],1,n,1);
				printf("%d\n",ans);
			}
			else
			{
				int a;
				scanf("%d",&a);
				update(num[a],1,n,1);
			}
		}
	}
}


POJ 题目3321 Apple Tree(线段树)

标签:each   arch   int   car   lin   img   images   iss   bsp   

原文地址:http://www.cnblogs.com/liguangsunls/p/7133815.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!