码迷,mamicode.com
首页 > 其他好文 > 详细

poj 2342 && hdu 1520

时间:2017-07-09 12:21:26      阅读:159      评论:0      收藏:0      [点我收藏+]

标签:clu   rar   range   stream   java   arc   rip   amp   integer   

Anniversary party

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11261    Accepted Submission(s): 4641


Problem Description
There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests‘ conviviality ratings.
 

 

Input
Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
0 0
 

 

Output
Output should contain the maximal sum of guests‘ ratings.
 

 

Sample Input
7 1 1 1 1 1 1 1 1 3 2 3 6 4 7 4 4 5 3 5 0 0
 

 

Sample Output
5
 
 
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<string>
#include<algorithm>
#include<iostream>
#include<queue>
#include<map>
#include<cmath>
#include<set>
#include<stack>
#define ll long long
#define pb push_back
#define max(x,y) ((x)>(y)?(x):(y))
#define min(x,y) ((x)>(y)?(y):(x))
#define cls(name,x) memset(name,x,sizeof(name))
using namespace std;
const int inf=1e9+10;
const ll llinf=1e16+10;
const int maxn=6e3+10;
const int maxm=1e2+10;
const int mod=1e9+7;
int n;
vector<int> v[maxn];
int dp[maxn][2];
int val[maxn];
int pre[maxn];
void solve(int rt)
{
    dp[rt][1]=val[rt];
    dp[rt][0]=0;
    for(int i=0;i<v[rt].size();i++)
    {
        int to=v[rt][i];
        solve(to);
        dp[rt][1]+=dp[to][0];
        dp[rt][0]+=max(dp[to][0],dp[to][1]);
    }
}
int main()
{
    //freopen("in.txt","r",stdin);
    while(~scanf("%d",&n))
    {
        for(int i=1;i<=n;i++)
            scanf("%d",&val[i]);
        for(int i=1;i<=n;i++)
            pre[i]=-1;
        int a,b;
        for(int i=1;i<=n;i++)
            v[i].clear();
        while(~scanf("%d %d",&a,&b)&&a!=0&&b!=0)
        {
            v[b].pb(a);
            pre[a]=b;
        }
        int rt=1;
        while(pre[rt]!=-1)
            rt=pre[rt];
        solve(rt);
        printf("%d\n",max(dp[rt][0],dp[rt][1]));
    }
    return 0;
}

 

poj 2342 && hdu 1520

标签:clu   rar   range   stream   java   arc   rip   amp   integer   

原文地址:http://www.cnblogs.com/mgz-/p/7140541.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!