码迷,mamicode.com
首页 > 编程语言 > 详细

POJ2155 Matrix 【二维树状数组】+【段更新点查询】

时间:2017-07-09 12:22:22      阅读:176      评论:0      收藏:0      [点我收藏+]

标签:for   eof   mon   write   树状数组   gb2312   sam   init   class   

Matrix
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 17766   Accepted: 6674

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N). 

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a ‘0‘ then change it into ‘1‘ otherwise change it into ‘0‘). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions. 

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2). 
2. Q x y (1 <= x, y <= n) querys A[x, y]. 

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case. 

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above. 

Output

For each querying output one line, which has an integer representing A[x, y]. 

There is a blank line between every two continuous test cases. 

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1

题意:对一个给定size且初始化为0的矩阵。运行一些命令,Q A B为查看arr[a][b]元素的值,C X1 Y1 X2 Y2为将(x1, y1) (x2, y2)矩形范围内的全部点0、1翻转。

题解:树状数组模式二的使用方法。段更新,点查询。update(x2, y2)表示从(1, 1)到(x2, y2)范围内的全部点都要翻转一次,可是这样会把给定范围外的一些点也翻转到,因此须要将这些点翻转回去。

#include <stdio.h>
#include <string.h>
#define maxn 1002

int size, tree[maxn][maxn];

int lowBit(int x){ return x & (-x); }

//向下更新表示A[1]...A[i]每一个元素都要 += val,推广到二维同理
void update(int x, int y, int val)
{
	int temp;
	while(x > 0){
		temp = y;
		while(temp > 0){
			tree[x][temp] += val;
			temp -= lowBit(temp);
		}
		x -= lowBit(x);
	}
}

int query(int x, int y)
{
	int sum = 0, temp;
	while(x <= size){
		temp = y;
		while(temp <= size){
			sum += tree[x][temp];
			temp += lowBit(temp);
		}
		x += lowBit(x);
	}
	return sum;
}

int main()
{
	//freopen("stdin.txt", "r", stdin);
	
	int cas, q, a, b, c, d;
	char com[2];
	scanf("%d", &cas);
	
	while(cas--){
		scanf("%d%d", &size, &q);
		memset(tree, 0, sizeof(tree));
		
		while(q--){
			scanf("%s%d%d", com, &a, &b);
			if(com[0] == 'C'){
				scanf("%d%d", &c, &d);
				update(c, b - 1, -1);
				update(a - 1, d, -1);
				update(a - 1, b - 1, 1);
				update(c, d, 1);
			}else printf("%d\n", query(a, b) & 1);
		}
		
		if(cas) printf("\n");
	}
	return 0;
}


POJ2155 Matrix 【二维树状数组】+【段更新点查询】

标签:for   eof   mon   write   树状数组   gb2312   sam   init   class   

原文地址:http://www.cnblogs.com/mthoutai/p/7140542.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!