码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1159 Palindrome

时间:2017-07-10 12:08:11      阅读:170      评论:0      收藏:0      [点我收藏+]

标签:problem   ide   with   ogr   nts   idt   names   回文   check   

Palindrome
Time Limit: 15000MS   Memory Limit: 65536K
Total Submissions: 9200   Accepted: 3465

Description

Andy the smart computer science student was attending an algorithms class when the professor asked the students a simple question, "Can you propose an efficient algorithm to find the length of the largest palindrome in a string?"

A string is said to be a palindrome if it reads the same both forwards and backwards, for example "madam" is a palindrome while "acm" is not.

The students recognized that this is a classical problem but couldn‘t come up with a solution better than iterating over all substrings and checking whether they are palindrome or not, obviously this algorithm is not efficient at all, after a while Andy raised his hand and said "Okay, I‘ve a better algorithm" and before he starts to explain his idea he stopped for a moment and then said "Well, I‘ve an even better algorithm!".

If you think you know Andy‘s final solution then prove it! Given a string of at most 1000000 characters find and print the length of the largest palindrome inside this string.

Input

Your program will be tested on at most 30 test cases, each test case is given as a string of at most 1000000 lowercase characters on a line by itself. The input is terminated by a line that starts with the string "END" (quotes for clarity).

Output

For each test case in the input print the test case number and the length of the largest palindrome.

Sample Input

abcbabcbabcba
abacacbaaaab
END

Sample Output

Case 1: 13
Case 2: 6

回文串模板题
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <map>
#include <set>
#include <vector>
#include <queue>
using namespace std;
typedef long long ll;
char a[2000009];
int p[2000009];
int main()
{
    int ans=0;
    while(scanf("%s",a))
    {
      if(a[0]==E && a[1]==N && a[2]==D) break;
        ans++;
        memset(p,0,sizeof(p));
        int len=strlen(a),id=0,maxlen=0;
        for(int i=len;i>=0;--i)
        {
            a[(i<<1)+1]=#;
            a[(i<<1)+2]=a[i];
        }
        for(int i=2;i<2*len-1;i++)
        {
            if(p[id]+id>i) p[i]=min(p[id*2-i],p[id]+id-i);
            else p[i]=1;
            while(a[i-p[i]]==a[i+p[i]]) ++p[i];
            if(id+p[id]<i+p[i])id=i;
            if(maxlen<p[i])maxlen=p[i];
        }
        printf("Case %d:",ans);
        printf(" %d\n",maxlen-1);
    }
    return 0;
}

 

 

POJ 1159 Palindrome

标签:problem   ide   with   ogr   nts   idt   names   回文   check   

原文地址:http://www.cnblogs.com/shinianhuanniyijuhaojiubujian/p/7144944.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!