码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1027 Ignatius and the Princess II

时间:2017-07-18 22:16:50      阅读:236      评论:0      收藏:0      [点我收藏+]

标签:break   printf   use   fst   cas   panel   always   help   模拟   

原题代号:HDU 1027

原题链接:http://acm.hdu.edu.cn/showproblem.php?pid=1027

原题描述:

Ignatius and the Princess II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8415    Accepted Submission(s): 4955

Problem Description
Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, "I have three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too." Ignatius says confidently, "OK, at last, I will save the Princess."

"Now I will show you the first problem." feng5166 says, "Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it‘s easy to see the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It‘s easy, isn‘t is? Hahahahaha......"
Can you help Ignatius to solve this problem?
 
Input
The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub‘s demand. The input is terminated by the end of file.
 
Output
For each test case, you only have to output the sequence satisfied the BEelzebub‘s demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number.
 
Sample Input
6 4
11 8
 
Sample Output
1 2 3 5 6 4
1 2 3 4 5 6 7 9 8 11 10
 
题目大意:求出1-N个数排列当中第M小的排列
没什么好说的,自己找的个规律,然后模拟了一下操作,所以就直接贴代码了
AC代码:
# include <stdio.h>
# include <string.h>
# include <stdlib.h>
# include <iostream>
# include <fstream>
# include <vector>
# include <queue>
# include <stack>
# include <map>
# include <math.h>
# include <algorithm>
using namespace std;
# define pi acos(-1.0)
# define mem(a,b) memset(a,b,sizeof(a))
# define FOR(i,a,n) for(int i=a; i<=n; ++i)
# define For(i,n,a) for(int i=n; i>=a; --i)
# define FO(i,a,n) for(int i=a; i<n; ++i)
# define Fo(i,n,a) for(int i=n; i>a ;--i)
typedef long long LL;
typedef unsigned long long ULL;

int ans[10]={1},num[10],sum,a[1005];

void swap_(int &b,int &c)
{
    int t;
    t=b,b=c,c=t;
}

int main()
{
    for(int i=1;i<=8;i++)
    {
        ans[i]=ans[i-1]*i;
    }
/*    for(int i=1;i<=10;i++)
        cout<<ans[i]<<endl;*/
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        for(int i=1;i<=n;i++)
            a[i]=i;
        mem(num,0);
        sum=0;
        while(m>1)
        {
            for(int i=8;i>=1;i--)
                if(m>ans[i])
                {
                    m-=ans[i],num[i]++,sum++;
                    break;
                }
        }
/*        cout<<sum<<endl;
        for(int i=1;i<=8;i++)
            printf("%2d,,%d\n",i,num[i]);*/
        while(sum)
        {
            for(int i=8;i>=1;i--)
            {
                if(num[i])
                {
                    swap_(a[n-i],a[n-i+num[i]]);
                    sort(a+n-i+1,a+n+1);
                    sum-=num[i];
                    num[i]=0;
                }
            }
        }
        for(int i=1;i<=n;i++)
            printf(i==1?"%d":" %d",a[i]);
        cout<<endl;
    }
    return 0;
}

  

HDU 1027 Ignatius and the Princess II

标签:break   printf   use   fst   cas   panel   always   help   模拟   

原文地址:http://www.cnblogs.com/teble/p/7202771.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!