码迷,mamicode.com
首页 > 其他好文 > 详细

[ACM] hdu 1029 Ignatius and the Princess IV (动归或hash)

时间:2017-07-21 12:27:05      阅读:148      评论:0      收藏:0      [点我收藏+]

标签:contains   scan   --   min   roi   not   back   java   去掉   

Ignatius and the Princess IV

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32767K (Java/Other)
Total Submission(s) : 7   Accepted Submission(s) : 3

Font: Times New Roman | Verdana | Georgia

Font Size:  

Problem Description

 

"OK, you are not too bad, em... But you can never pass the next test." feng5166 says.

"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says.

"But what is the characteristic of the special integer?" Ignatius asks.

"The integer will appear at least (N+1)/2 times. If you can‘t find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says.

Can you find the special integer for Ignatius?

 

Input

 

The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.

 

Output

 

For each test case, you have to output only one line which contains the special number you have found.

 

Sample Input

 

5
1 3 2 3 3
11
1 1 1 1 1 5 5 5 5 5 5
7
1 1 1 1 1 1 1

 

Sample Output

 

3
5
1

 

Author

 

Ignatius.L

 

解题思路:

给出n个数。n为奇数。求在里面至少出现(n+1)/2 次的那个数。

方法一:

同等消除。比方数 -1 -2  3 3 3 -2 ,消除一次-1 3 -2 去掉。剩余3 3 -2 。再消除一次 剩余3,3就是所求。

代码:

#include <iostream>
#include <stdio.h>
#include <algorithm>
using namespace std;

int main()
{
    int n;
    int num,cnt,r;
    while(scanf("%d",&n)!=EOF)//一定得写上。EOF 
    {
        cnt=0;
        while(n--)
        {
            scanf("%d",&num);
            if(cnt==0)
            {
                r=num;
                cnt=1;
            }
            if(num==r)
                cnt++;
            else
                cnt--;

        }
        printf("%d\n",r);
    }
    return 0;
}


方法二:hash打表。

代码:

#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
const int maxn=1000005;
int hash[maxn];

int main()
{
    int n,num,r;
    while(scanf("%d",&n)!=EOF)
    {
        memset(hash,0,sizeof(hash));
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&num);
            hash[num]++;
            if(hash[num]>n/2)
            {
                r=num;//找到了也不能break掉。由于有可能还没有输入完成
            }
        }
        printf("%d\n",r);
    }
    return 0;
}


 

 

[ACM] hdu 1029 Ignatius and the Princess IV (动归或hash)

标签:contains   scan   --   min   roi   not   back   java   去掉   

原文地址:http://www.cnblogs.com/claireyuancy/p/7216833.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!