码迷,mamicode.com
首页 > 其他好文 > 详细

poj 2891 模数不互质的中国剩余定理

时间:2017-07-21 19:56:00      阅读:227      评论:0      收藏:0      [点我收藏+]

标签:scribe   while   read   res   sts   stdin   ssi   put   written   

Strange Way to Express Integers

Description

 

Elina is reading a book written by Rujia Liu, which introduces a strange way to express non-negative integers. The way is described as following:

 

Choose k different positive integers a1a2…, ak. For some non-negative m, divide it by every ai (1 ≤ i ≤ k) to find the remainder ri. If a1a2, …, ak are properly chosen, m can be determined, then the pairs (airi) can be used to express m.

“It is easy to calculate the pairs from m, ” said Elina. “But how can I find m from the pairs?”

Since Elina is new to programming, this problem is too difficult for her. Can you help her?

Input

The input contains multiple test cases. Each test cases consists of some lines.

  • Line 1: Contains the integer k.
  • Lines 2 ~ k + 1: Each contains a pair of integers airi (1 ≤ i ≤ k).

 

Output

Output the non-negative integer m on a separate line for each test case. If there are multiple possible values, output the smallest one. If there are no possible values, output -1.

 

Sample Input

2
8 7
11 9

Sample Output

31

Hint

All integers in the input and the output are non-negative and can be represented by 64-bit integral types.

 

 

 

题意:

就是给你n组数据

每一组数据a,b   表示    x%a==b

求这n组数据的公共的最小x的解

 

 

题解:

中国剩余定理中的不互质的模线性方程组

由不互质的模线性方程组
x%r1=a1              1
x%r2=a2              2
x%r3=a3              3
x%r4=a4              4
......
由  1  2式子得到:
x = r1*k1 + a1
x = r2*k2 + a2
联立:
r1*k1 + a1 =r2*k2 + a2
得到
r1*k1 + r2*k2 = a2 - a1  (其中k2的正负可变)

令g=gcd(r1,r2)

那么上叙方程同时除以g后

r1*k1 / g + r2*k2 / g = (a2 - a1 )/ g            

 

由扩展欧几里得可以得到k1,则有
x1 = r1*k1 + a1                         5
     x1表示1 2式子得到的r1 和 让r2的最大公约数

上ac代码:

#include<stdio.h>  
#include<string.h>  
#include<algorithm>  
using namespace std;  
  
  
#define LL long long  
  
  
LL exgcd(LL a,LL b,LL &x,LL &y)  
{  
    if(b==0){  
        x=1,y=0;  
        return a;  
    }  
  
  
    LL d=exgcd(b,a%b,y,x);  
    y-=(a/b)*x;  
    return d;  
}  
  
  
int main()  
{  
    LL k,a1,a2,r1,r2;  
    LL x,y,d;  
   // freopen("in.txt","r",stdin);  
    while(scanf("%I64d",&k)!=EOF)  
    {  
        scanf("%I64d%I64d",&a1,&r1);  
        k--;  
        int flag=0;  
        while(k--)  
        {  
            scanf("%I64d%I64d",&a2,&r2);  
            if(flag)  
                continue;  
  
  
            //扩展欧几里得  
            LL a=a1,b=a2;  
            LL c=r2-r1;  
            d=exgcd(a,b,x,y);//最小公约数  
            if(c%d){  
                flag=1;  
                continue;  
            }  
              
            LL t=b/d;//除以d表示方程两边都除以d  
            x=(x*(c/d)%t+t)%t;  
            r1=a1*x+r1;//同上面所说的式子5  
            a1=a1*(a2/d);//a1 a2最大公倍数  
        }  
  
  
        if(flag)  
            printf("-1\n");  
        else  
            printf("%I64d\n",r1);  
    }  
    return 0;  
}  

 

poj 2891 模数不互质的中国剩余定理

标签:scribe   while   read   res   sts   stdin   ssi   put   written   

原文地址:http://www.cnblogs.com/z1141000271/p/7219271.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!