码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 2164(模拟)

时间:2017-07-22 09:39:51      阅读:121      评论:0      收藏:0      [点我收藏+]

标签:sso   term   eterm   win   end   strong   where   scanf   value   

Rock, Paper, or Scissors?

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2927    Accepted Submission(s): 1873


Problem Description
Rock, Paper, Scissors is a two player game, where each player simultaneously chooses one of the three items after counting to three. The game typically lasts a pre-determined number of rounds. The player who wins the most rounds wins the game. Given the number of rounds the players will compete, it is your job to determine which player wins after those rounds have been played.

The rules for what item wins are as follows:

?Rock always beats Scissors (Rock crushes Scissors)
?Scissors always beat Paper (Scissors cut Paper)
?Paper always beats Rock (Paper covers Rock)
 

 

Input
The first value in the input file will be an integer t (0 < t < 1000) representing the number of test cases in the input file. Following this, on a case by case basis, will be an integer n (0 < n < 100) specifying the number of rounds of Rock, Paper, Scissors played. Next will be n lines, each with either a capital R, P, or S, followed by a space, followed by a capital R, P, or S, followed by a newline. The first letter is Player 1抯 choice; the second letter is Player 2抯 choice.

 

 

Output
For each test case, report the name of the player (Player 1 or Player 2) that wins the game, followed by a newline. If the game ends up in a tie, print TIE.
 

 

Sample Input
3 2 R P S R 3 P P R S S R 1 P R
 

 

Sample Output
Player 2 TIE Player 1
#include <iostream>
#include<cstdio>
using namespace std;

int main()
{
    int t;
    int n;
    char c1,c2;
    int s1,s2;
    scanf("%d",&t);
    while(t--)
    {
        s1=s2=0;//!!注意初始化位置
        scanf("%d",&n);
        getchar();//
        while(n--)
        {
            scanf("%c %c",&c1,&c2);
            getchar();//
            if(c1==c2) continue;
            else if(c1==‘R‘&&c2==‘S‘||c1==‘S‘&&c2==‘P‘||c1==‘P‘&&c2==‘R‘)
            {
                s1++;
            }
            else
                s2++;
        }
            if(s1==s2) printf("TIE\n");
            else if(s1>s2)  printf("Player 1\n");
            else  printf("Player 2\n");
    }
    return 0;
}

  

HDU 2164(模拟)

标签:sso   term   eterm   win   end   strong   where   scanf   value   

原文地址:http://www.cnblogs.com/Roni-i/p/7220277.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!