码迷,mamicode.com
首页 > 其他好文 > 详细

KMP——hdu 3336 count the string

时间:2017-07-24 00:18:02      阅读:178      评论:0      收藏:0      [点我收藏+]

标签:highlight   ++   cas   hat   有一个   --   ret   include   and   

Count the string

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10478    Accepted Submission(s): 4893


Problem Description
It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: "abab"
The prefixes are: "a", "ab", "aba", "abab"
For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.
 

 

Input
The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.
 

 

Output
For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.
 

 

Sample Input
1 4 abab
 

 

Sample Output
6
 
KMP算法中next数组的妙用
通过next数组的定义,我们可以知道next[j]=i表示以j结尾的最长前缀的终点位置为i。
用dp的思想考虑:每加一个字符会增加几个前缀?
首先至少有一个从0到本身的前缀,然后根据next数组又得到已j为结尾的最长前缀的终点位置i
所以dp[j]=dp[next[i]]+1;
dp[j]表示第j个字符加入时会增加几个前缀。
 
#include <iostream>
#define mod 10007
using namespace std;
int l;
const int maxl= 200000+10;
char a[maxl];
int nextl[maxl];
int dp[maxl];
void get_next()
{
    nextl[0]=-1;
    for(int i=1;i<l;i++)
    {
        int j=nextl[i-1];
        while(a[j+1]!=a[i]&&j>-1)
            j=nextl[j];
        nextl[i]=(a[j+1]==a[i])?j+1:-1;
    }
}
void solve()
{
    get_next();
    dp[0]=1;
    int ans=1;
    for(int i=1;i<l;i++)
    {
        dp[i]=(nextl[i]>=0)?dp[nextl[i]]+1:1;
        ans=(ans+dp[i])%mod;
    }
    cout<<ans<<endl;
}
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        cin>>l>>a;
        solve();
    }
    return 0;
}

  

 

KMP——hdu 3336 count the string

标签:highlight   ++   cas   hat   有一个   --   ret   include   and   

原文地址:http://www.cnblogs.com/onlyli/p/7226323.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!