码迷,mamicode.com
首页 > 其他好文 > 详细

Robot Motion

时间:2017-07-24 22:34:15      阅读:178      评论:0      收藏:0      [点我收藏+]

标签:cout   starting   iostream   through   mem   immediate   数组   art   step   

A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are 

N north (up the page) 
S south (down the page) 
E east (to the right on the page) 
W west (to the left on the page) 

For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid. 

Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits. 

You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around. 

InputThere will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0. 
OutputFor each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1. 
Sample Input

3 6 5
NEESWE
WWWESS
SNWWWW
4 5 1
SESWE
EESNW
NWEEN
EWSEN
0 0 

Sample Output

10 step(s) to exit
3 step(s) before a loop of 8 step(s)

这题没有什么难度,判断循环那里利用一个整型数组就能轻松解决
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
int main()
{
    char s[10][10];
    int q[10][10];
    int a,b,c;
    while(cin>>a>>b)
    {
        memset(q,0,sizeof(q));
        if(a==0&&b==0)
            break;
        cin>>c;
        for(int i=0;i<a;i++)
            for(int j=0;j<b;j++)
                cin>>s[i][j];
        int i=0,j=c-1,step=0,flag=0;
        while((i>=0&&i<=a-1)&&(j>=0&&j<=b-1))
        {
            if(q[i][j]!=0)
            {
                int s=q[i][j]-1;
                cout<<s<<" step(s) before a loop of "<<step-s<<" step(s)"<<endl;
                flag=1;
                break;
            }
            char ch=s[i][j];
            q[i][j]=step+1;
            if(ch==‘N‘)
            {
                i--;
                step++;
            }
            else if(ch==‘S‘)
            {
                i++;
                step++;
            }
            else if(ch==‘E‘)
            {
                j++;
                step++;
            }
            else
            {
                j--;
                step++;
            }
        }
        if(flag==0)
        cout<<step<<" step(s) to exit"<<endl;
    }
    return 0;
}

  

Robot Motion

标签:cout   starting   iostream   through   mem   immediate   数组   art   step   

原文地址:http://www.cnblogs.com/zzzying/p/7231191.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!