码迷,mamicode.com
首页 > 其他好文 > 详细

poj 1733带权并查集

时间:2014-09-02 19:58:25      阅读:263      评论:0      收藏:0      [点我收藏+]

标签:并查集   数据结构   

L - Parity game
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

Now and then you play the following game with your friend. Your friend writes down a sequence consisting of zeroes and ones. You choose a continuous subsequence (for example the subsequence from the third to the fifth digit inclusively) and ask him, whether this subsequence contains even or odd number of ones. Your friend answers your question and you can ask him about another subsequence and so on. Your task is to guess the entire sequence of numbers. 

You suspect some of your friend‘s answers may not be correct and you want to convict him of falsehood. Thus you have decided to write a program to help you in this matter. The program will receive a series of your questions together with the answers you have received from your friend. The aim of this program is to find the first answer which is provably wrong, i.e. that there exists a sequence satisfying answers to all the previous questions, but no such sequence satisfies this answer.

Input

The first line of input contains one number, which is the length of the sequence of zeroes and ones. This length is less or equal to 1000000000. In the second line, there is one positive integer which is the number of questions asked and answers to them. The number of questions and answers is less or equal to 5000. The remaining lines specify questions and answers. Each line contains one question and the answer to this question: two integers (the position of the first and last digit in the chosen subsequence) and one word which is either `even‘ or `odd‘ (the answer, i.e. the parity of the number of ones in the chosen subsequence, where `even‘ means an even number of ones and `odd‘ means an odd number).

Output

There is only one line in output containing one integer X. Number X says that there exists a sequence of zeroes and ones satisfying first X parity conditions, but there exists none satisfying X+1 conditions. If there exists a sequence of zeroes and ones satisfying all the given conditions, then number X should be the number of all the questions asked.

Sample Input

10
5
1 2 even
3 4 odd
5 6 even
1 6 even
7 10 odd

Sample Output

3



#include<iostream>
#include<algorithm>
#include<cstdio>
#include<vector>
#include<string>
#include<queue>
#include<map>
#include<cmath>
#include<cstring>
using namespace std;
const int maxn= 10005;
typedef long long LL;
int p[maxn],d[maxn];
void init(int n)
{
    for(int i=1;i<=n;i++){
        p[i]=i;
        d[i]=0;
    }
}
int findx(int x)
{
    if(p[x]==x)return x;
    int root=findx(p[x]);
    d[x]+=d[p[x]];
    d[x]%=2;
    return p[x]=root;
}
bool Union(int x,int y,int op)
{
    int u=findx(x),v=findx(y);
    if(u!=v)
    {
        p[u]=v;
        d[u]=(d[x]-d[y]+op+2)%2;
        return true;
    }
    return d[x]==(op+d[y])%2==op;
}
int main()
{
    map<int,int>q;
    int cnt=0,n,qus;

    scanf("%d",&n);
    scanf("%d",&qus);
    init(qus*2+4);

    int a,b,ans=-1;
    char cmd[5];
    for(int i=0;i<qus;i++)
    {
        scanf("%d%d%s",&a,&b,cmd);
        b++;
        if(!q[a])q[a]=++cnt;
        if(!q[b])q[b]=++cnt;
        if(ans<0&&!Union(q[a],q[b],cmd[0]=='o'))
        {
            ans=i;break;
        }
    }
    printf("%d\n",ans>-1?ans:qus);
    return 0;
}

存题


poj 1733带权并查集

标签:并查集   数据结构   

原文地址:http://blog.csdn.net/acvcla/article/details/39010079

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!