码迷,mamicode.com
首页 > 其他好文 > 详细

2017ecjtu-summer training #1 UVA 10399

时间:2017-07-29 17:38:56      阅读:136      评论:0      收藏:0      [点我收藏+]

标签:rect   iostream   uva   for   clu   integer   nes   correct   span   

It has been said that a watch that is stopped keeps better time than one that loses 1 second per day.

The one that is stopped reads the correct time twice a day while the one that loses 1 second per day is correct only once every 43,200 days.

This maxim applies to old fashioned 12-hour analog watches, whose hands move continuously (most digital watches would display nothing at all if stopped).

Given two such analog watches, both synchronized to midnight, that keep time at a constant rate but run slow by k and m seconds per day respectively, what time will the watches show when next they have exactly the same time?

Input

Input consists of a number of lines, each with two distinct non-negative integers k and m between 0 and 256, indicating the number of seconds per day that each watch loses.

Output

For each line of input, print k, m, and the time displayed on each watch, rounded to the nearest minute. Valid times range from 01:00 to 12:59.

Sample Input

1 2

0 7

Sample Output

1 2 12:00

0 7 10:17

题意 两个表一个表一天慢k秒,另一个表一天慢m秒,问下一次相同的时间是多少

表的一圈是43200秒,一天是86400秒

追及问题 经过43200/m-k天再次时间一样

此时 表走了( 43200/m-k )*( 86400-k )秒

AC代码

#include <stdio.h>
#include <math.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <sstream>
#include <queue>
#include <vector>
#include <algorithm>
#define maxn 100010
using namespace std;
typedef long long ll;
int main()
{
    int k,m;
    int min,h;
    while(scanf("%d%d",&k,&m)!=EOF)
    {
        int a=abs(m-k);
        ll s=(ll)(43200.0/a*(86400.0-k));            
        s%=43200;                         //这些天转了s/43200圈后剩余的秒数           
        int min=s/60;                     //求出分钟数 
        s%=60;                            //rounded to the nearest minute 
        if(s>=30)
           min++; 
        int h=min/60;                     //求出小时数 
        min%=60;                          // 分的时间 
        h%=12;                            // 没有0点换成12点 
        if(h==0)
           h=12;
        printf("%d %d %02d:%02d\n", k, m, h, min);//格式输出 
    }
}

 

2017ecjtu-summer training #1 UVA 10399

标签:rect   iostream   uva   for   clu   integer   nes   correct   span   

原文地址:http://www.cnblogs.com/stranger-/p/7256840.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!