码迷,mamicode.com
首页 > 其他好文 > 详细

HDU6043 KazaQ's Socks

时间:2017-07-31 12:35:25      阅读:123      评论:0      收藏:0      [点我收藏+]

标签:string   int   ott   inpu   msu   script   ase   sam   review   

Problem Description
KazaQ wears socks everyday.

At the beginning, he has n pairs of socks numbered from 1 to n in his closets. 

Every morning, he puts on a pair of socks which has the smallest number in the closets. 

Every evening, he puts this pair of socks in the basket. If there are n1 pairs of socks in the basket now, lazy KazaQ has to wash them. These socks will be put in the closets again in tomorrow evening.

KazaQ would like to know which pair of socks he should wear on the k-th day.
 

 

Input
The input consists of multiple test cases. (about 2000)

For each case, there is a line contains two numbers n,k (2n109,1k1018).
 

 

Output
For each test case, output "Case #xy" in one line (without quotes), where x indicates the case number starting from 1 and y denotes the answer of corresponding case.
 

 

Sample Input
3 7 3 6 4 9
 

 

Sample Output
Case #1: 3 Case #2: 1 Case #3: 2
 
Code:
#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <ctime>
#include <ctype.h>

using namespace std;


int main()
{
    long long int n,k,cnt=0;
    while(cin>>n>>k)
    {
        if(n>=k)
            cout<<"Case #"<<cnt++<<": "<<k<<endl;
        else
        {
            int a=(k-n)/(n-1),b=(k-n)%(n-1);
            if(b!=0)
                cout<<"Case #"<<cnt++<<": "<<b<<endl;
            else
            {
                if(a%2==0)
                    cout<<"Case #"<<cnt++<<": "<<n<<endl;
                else
                    cout<<"Case #"<<cnt++<<": "<<n-1<<endl;
            }
        }
    }
    return 0;
}

 

HDU6043 KazaQ's Socks

标签:string   int   ott   inpu   msu   script   ase   sam   review   

原文地址:http://www.cnblogs.com/gonsedup/p/7262411.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!