码迷,mamicode.com
首页 > 其他好文 > 详细

poj1206(dp)

时间:2017-07-31 21:13:16      阅读:119      评论:0      收藏:0      [点我收藏+]

标签:iostream   enter   情况   cat   line   ace   with   ordinary   推出   

题目链接:http://poj.org/problem?id=1260

Pearls
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 7984   Accepted: 3970

Description

In Pearlania everybody is fond of pearls. One company, called The Royal Pearl, produces a lot of jewelry with pearls in it. The Royal Pearl has its name because it delivers to the royal family of Pearlania. But it also produces bracelets and necklaces for ordinary people. Of course the quality of the pearls for these people is much lower then the quality of pearls for the royal family.In Pearlania pearls are separated into 100 different quality classes. A quality class is identified by the price for one single pearl in that quality class. This price is unique for that quality class and the price is always higher then the price for a pearl in a lower quality class. 
Every month the stock manager of The Royal Pearl prepares a list with the number of pearls needed in each quality class. The pearls are bought on the local pearl market. Each quality class has its own price per pearl, but for every complete deal in a certain quality class one has to pay an extra amount of money equal to ten pearls in that class. This is to prevent tourists from buying just one pearl. 
Also The Royal Pearl is suffering from the slow-down of the global economy. Therefore the company needs to be more efficient. The CFO (chief financial officer) has discovered that he can sometimes save money by buying pearls in a higher quality class than is actually needed.No customer will blame The Royal Pearl for putting better pearls in the bracelets, as long as the 
prices remain the same. 
For example 5 pearls are needed in the 10 Euro category and 100 pearls are needed in the 20 Euro category. That will normally cost: (5+10)*10+(100+10)*20 = 2350 Euro.Buying all 105 pearls in the 20 Euro category only costs: (5+100+10)*20 = 2300 Euro. 
The problem is that it requires a lot of computing work before the CFO knows how many pearls can best be bought in a higher quality class. You are asked to help The Royal Pearl with a computer program. 

Given a list with the number of pearls and the price per pearl in different quality classes, give the lowest possible price needed to buy everything on the list. Pearls can be bought in the requested,or in a higher quality class, but not in a lower one. 

Input

The first line of the input contains the number of test cases. Each test case starts with a line containing the number of categories c (1<=c<=100). Then, c lines follow, each with two numbers ai and pi. The first of these numbers is the number of pearls ai needed in a class (1 <= ai <= 1000). 
The second number is the price per pearl pi in that class (1 <= pi <= 1000). The qualities of the classes (and so the prices) are given in ascending order. All numbers in the input are integers. 

Output

For each test case a single line containing a single number: the lowest possible price needed to buy everything on the list. 

Sample Input

2
2
100 1
100 2
3
1 10
1 11
100 12

Sample Output

330
1344

 

 

题目大意:经典dp,两种花费情况,求最小。

分析:dp[i]表示到第i个物品时的最优解,推出公式:dp[i]=dp[j]+(sum[i]-sum[j]+10)*p[i]。sum为前 i 项和;

 

#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
#define ll long long
const double eps = 1e-6;
const double pi = acos(-1.0);
const int INF = 0x3f3f3f3f;
const int MOD = 1000000007;

int n,a[1005],p[1005];
int sum[1005],dp[1005];

int main ()
{
    int T;
    scanf ("%d",&T);
    while (T--)
    {
        scanf ("%d",&n);
        memset(dp, 0, sizeof(dp));
        memset(sum, 0, sizeof(sum));
        for (int i=1; i<=n; i++)
        {
            scanf ("%d%d",&a[i],&p[i]);
            sum[i] = sum[i-1]+a[i];
        }
        int ans=0;
        for (int i=1; i<=n; i++)
        {
            int minx = INF;
            for (int j=0; j<i; j++)
            {
                dp[i] = dp[j]+(sum[i]-sum[j]+10)*p[i];
                if (minx > dp[i]) minx=dp[i];
            }
            dp[i] = minx;
        }
        printf ("%d\n",dp[n]);
    }
    return 0;
}


 

poj1206(dp)

标签:iostream   enter   情况   cat   line   ace   with   ordinary   推出   

原文地址:http://www.cnblogs.com/liguangsunls/p/7265655.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!