码迷,mamicode.com
首页 > 其他好文 > 详细

[ACM] POJ 2151 Check the difficulty of problems (概率+DP)

时间:2017-08-03 16:58:10      阅读:181      评论:0      收藏:0      [点我收藏+]

标签:check   cal   ted   difficult   cer   ssi   mem   lang   ref   

Check the difficulty of problems
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 4748   Accepted: 2078

Description

Organizing a programming contest is not an easy job. To avoid making the problems too difficult, the organizer usually expect the contest result satisfy the following two terms: 
1. All of the teams solve at least one problem. 
2. The champion (One of those teams that solve the most problems) solves at least a certain number of problems. 

Now the organizer has studied out the contest problems, and through the result of preliminary contest, the organizer can estimate the probability that a certain team can successfully solve a certain problem. 

Given the number of contest problems M, the number of teams T, and the number of problems N that the organizer expect the champion solve at least. We also assume that team i solves problem j with the probability Pij (1 <= i <= T, 1<= j <= M). Well, can you calculate the probability that all of the teams solve at least one problem, and at the same time the champion team solves at least N problems? 

Input

The input consists of several test cases. The first line of each test case contains three integers M (0 < M <= 30), T (1 < T <= 1000) and N (0 < N <= M). Each of the following T lines contains M floating-point numbers in the range of [0,1]. In these T lines, the j-th number in the i-th line is just Pij. A test case of M = T = N = 0 indicates the end of input, and should not be processed.

Output

For each test case, please output the answer in a separate line. The result should be rounded to three digits after the decimal point.

Sample Input

2 2 2
0.9 0.9
1 0.9
0 0 0

Sample Output

0.972

Source

POJ Monthly,鲁小石


解题思路:

这道题太无语了...特别不好理解...... 概率,概率,概率......

题意为 有T个队參加ACM比赛。一共同拥有M道题,问全部的队都至少做出一道题且冠军队做出的题目不能少于N道的概率。

dp[1010][32][32];//dp[i][j][k]表示第i个队前j道题中做出k道
p[1010][32];//p[i][j] 表示第i个队做出第j道题的概率
s[1010][32];//s[i][j]表示第i各队做出的题目小于等于j道的概率

转载于:http://www.cnblogs.com/kuangbin/archive/2012/10/02/2710606.html

设dp[i][j][k]表示第i个队在前j道题中解出k道的概率
则:
dp[i][j][k]=dp[i][j-1][k-1]*p[j][k]+dp[i][j-1][k]*(1-p[j][k]);
先初始化算出dp[i][0][0]和dp[i][j][0];
设s[i][k]表示第i队做出的题小于等于k的概率
则s[i][k]=dp[i][M][0]+dp[i][M][1]+``````+dp[i][M][k];


则每一个队至少做出一道题概率为P1=(1-s[1][0])*(1-s[2][0])*```(1-s[T][0]);
每一个队做出的题数都在1~N-1的概率为P2=(s[1][N-1]-s[1][0])*(s[2][N-1]-s[2][0])*```(s[T][N-1]-s[T][0]);


最后的答案就是P1-P2

代码:

#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
double dp[1010][32][32];//dp[i][j][k]表示第i个队前j道题中做出k道
double p[1010][32];//p[i][j] 表示第i个队做出第j道题的概率
double s[1010][32];//s[i][j]表示第i各队做出的题目小于等于j道的概率
int m,n,t;

int main()
{
    while(scanf("%d%d%d",&m,&t,&n)!=EOF&&(m||t||n))
    {
        for(int i=1;i<=t;i++)
            for(int j=1;j<=m;j++)
            scanf("%lf",&p[i][j]);

        for(int i=1;i<=t;i++)
        {
            dp[i][0][0]=1;
            for(int j=1;j<=m;j++)
                dp[i][j][0]=dp[i][j-1][0]*(1-p[i][j]);//第i个队前j道题目都做不出来的概率

            for(int j=1;j<=m;j++)
                for(int k=1;k<=j;k++)
                dp[i][j][k]=dp[i][j-1][k-1]*p[i][j]+dp[i][j-1][k]*(1-p[i][j]);
            //第i个队前j道题做出k道的概率等于前j-1道题做出k-1道,第j道做出来加上前j-1道做出k道,第j道没做出来的概率和

            s[i][0]=dp[i][m][0];
            for(int j=1;j<=m;j++)
                s[i][j]=s[i][j-1]+dp[i][m][j];//依据上面的s数组求法可得递推公式
        }
        double p1=1,p2=1;
        for(int i=1;i<=t;i++)
        {
            p1*=(1-s[i][0]);//全部的队至少做出一题的概率
            p2*=(s[i][n-1]-s[i][0]);//全部的队都做出来1到n-1道题
        }
        printf("%.3lf\n",p1-p2);
    }
    return 0;
}


[ACM] POJ 2151 Check the difficulty of problems (概率+DP)

标签:check   cal   ted   difficult   cer   ssi   mem   lang   ref   

原文地址:http://www.cnblogs.com/gccbuaa/p/7280271.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!