码迷,mamicode.com
首页 > 其他好文 > 详细

Olympiad

时间:2017-08-03 22:13:20      阅读:188      评论:0      收藏:0      [点我收藏+]

标签:iostream   ssi   ret   beat   ica   describe   led   http   line   

You are one of the competitors of the Olympiad in numbers. The problem of this year relates to beatiful numbers. One integer is called beautiful if and only if all of its digitals are different (i.e. 12345 is beautiful, 11 is not beautiful and 100 is not beautiful). Every time you are asked to count how many beautiful numbers there are in the interval [a,b] (ab)[a,b] (a≤b). Please be fast to get the gold medal! 

InputThe first line of the input is a single integer T (T1000)T (T≤1000), indicating the number of testcases. 

For each test case, there are two numbers aa and bb, as described in the statement. It is guaranteed that 1ab1000001≤a≤b≤100000. 
OutputFor each testcase, print one line indicating the answer. 
Sample Input

2
1 10
1 1000

Sample Output

10
738
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<set>
#include<vector>
#include<stack>
#include<queue>
#include<algorithm>
#include<cstdio>
#include<algorithm>
#include<functional>
#include<sstream>
using namespace std;
int s[100001];
int main()
{
    memset(s, 0, sizeof(s));
    int flag[10];
    for (int i = 1; i <= 100000; i++)
    {
        int j = i;
        s[i] = 1;
        memset(flag, 0, sizeof(flag));
        while (j)
        {
            flag[j % 10]++;
            if (flag[j % 10] > 1)s[i] = 0;
            j /= 10;
        }
        s[i] += s[i - 1];
    }
    int l, r;
    int t;
    scanf("%d", &t);
    while (t--)
    {
        scanf("%d%d", &l, &r);
        printf("%d\n", s[r] - s[l - 1]);
    }
    return 0;
}

 

Olympiad

标签:iostream   ssi   ret   beat   ica   describe   led   http   line   

原文地址:http://www.cnblogs.com/edych/p/7281500.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!