码迷,mamicode.com
首页 > 其他好文 > 详细

使用内置函数sort,强烈推荐。

时间:2014-09-04 11:45:39      阅读:186      评论:0      收藏:0      [点我收藏+]

标签:style   blog   http   color   io   使用   ar   strong   for   

题目描述:

用一维数组存储学号和成绩,然后,按成绩排序输出。

输入:

输入第一行包括一个整数N(1<=N<=100),代表学生的个数。
接下来的N行每行包括两个整数p和q,分别代表每个学生的学号和成绩。

输出:

按照学生的成绩从小到大进行排序,并将排序后的学生信息打印出来。
如果学生的成绩相同,则按照学号的大小进行从小到大排序。

样例输入:
3
1 90
2 87
3 92
样例输出:
2 87
1 90
3 92
来源:
2009年华中科技大学计算机研究生机试真题
#include "stdio.h"
#include "algorithm"
 
using namespace std;
 
typedef struct stu{
    int p;      //学号
    int q;      //成绩
}stu;
 
bool cmp(stu a,stu b){
    if(a.q!=b.q)
        if(a.q<b.q)
            return true;
        else
            return false;   
    if(a.p!=b.p)
        if(a.p<b.p)
            return true;
        else
            return false;
}
 
int main(int argc, char* argv[])
{
    stu arr[100];
    int N,i;
    while(scanf("%d",&N)!=EOF){
        for(i=0;i<=N-1;i++)
            scanf("%d%d",&arr[i].p,&arr[i].q);
        sort(arr,arr+N,cmp);
        for(i=0;i<=N-1;i++)
            printf("%d %d\n",arr[i].p,arr[i].q);
    }
    return 0;
}

 

使用内置函数sort,强烈推荐。

标签:style   blog   http   color   io   使用   ar   strong   for   

原文地址:http://www.cnblogs.com/Murcielago/p/3955720.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!