码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1022 Train Problem I

时间:2017-08-13 09:52:42      阅读:144      评论:0      收藏:0      [点我收藏+]

标签:tail   top   std   mos   font   stat   eterm   ott   技术分享   

Problem Description
As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can‘t leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.
技术分享技术分享技术分享
 

Input
The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.
 

Output
The output contains a string "No." if you can‘t exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.
 

Sample Input
3 123 321 3 123 312
 

Sample Output
Yes. in in in out out out FINISH No. FINISH
Hint
Hint
For the first Sample Input, we let train 1 get in, then train 2 and train 3. So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1. In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3. Now we can let train 3 leave. But after that we can‘t let train 1 leave before train 2, because train 2 is at the top of the railway at the moment. So we output "No.".
 
都讲STL,是神器,今天我也来试试=。=;这题曾经写过看到网上大家都是一个做法。

果断STL;

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<limits.h>
#include<stack>
using namespace std;
const int maxn=110;
int main()
{
    stack<char>s;
    int n,i,j,k,r[maxn];//r数组记录的是s1进出栈的情况
    char s1[maxn],s2[maxn];
    while(cin>>n>>s1>>s2)
    {
        i=j=0;k=1;
        s.push(s1[0]);
        r[0]=1;
        while(i<n&&j<n)
        {
            if(!s.empty()&&s.top()==s2[j])
            {
                j++;
                s.pop();
                r[k++]=0;
            }
            else
            {
                if(i==n)  break;
                s.push(s1[++i]);
                r[k++]=1;
            }
        }
        if(i==n)
           cout<<"No."<<endl<<"FINISH"<<endl;
        else
        {
            cout<<"Yes."<<endl;
            for(int i=0;i<k;i++)
            {
                if(r[i])
                    cout<<"in"<<endl;
                else
                    cout<<"out"<<endl;
            }
            cout<<"FINISH"<<endl;
        }
    }
    return 0;
}


HDU 1022 Train Problem I

标签:tail   top   std   mos   font   stat   eterm   ott   技术分享   

原文地址:http://www.cnblogs.com/lytwajue/p/7352354.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!