码迷,mamicode.com
首页 > 其他好文 > 详细

Digit Counting UVA - 1225

时间:2017-08-15 10:07:57      阅读:106      评论:0      收藏:0      [点我收藏+]

标签:ati   following   ogr   sequence   seq   target   details   contain   显示   

Trung is bored with his mathematics homeworks. He takes a piece of chalk and starts writing a sequence of consecutive integers starting with 1 toN(1 < N < 10000) . After that, he counts the number of times each digit (0 to 9) appears in the sequence. For example, withN = 13 , the sequence is:

12345678910111213

In this sequence, 0 appears once, 1 appears 6 times, 2 appears 2 times, 3 appears 3 times, and each digit from 4 to 9 appears once. After playing for a while, Trung gets bored again. He now wants to write a program to do this for him. Your task is to help him with writing this program.

 

Input 

The input file consists of several data sets. The first line of the input file contains the number of data sets which is a positive integer and is not bigger than 20. The following lines describe the data sets.

For each test case, there is one single line containing the number N .

 

Output 

For each test case, write sequentially in one line the number of digit 0, 1,...9 separated by a space.

 

Sample Input 

 

2 
3 
13

 

Sample Output 

 

0 1 1 1 0 0 0 0 0 0 
1 6 2 2 1 1 1 1 1 1

这个题目刚做的时候觉得非常简单,一会就敲完啦,但交上去之后显示时间超时,问题出现在输入的数字上,在逻辑上面,我的程序已经出现了漏洞。不多说了,看代码吧;
#include<stdio.h>
#include<string.h>
#define maxn 10
int main()
{
    int N;
    int a[maxn];
    scanf("%d",&N);
    while(N--){
        int n,i,j;
        memset(a,0,sizeof(a));
        scanf("%d",&n);
        for(i=1;i<=n;i++){
             //for(j=i;j>0;j/=10)
               // a[j%10]++;
               j=i;
               while(j)
               {
                   a[j%10]++;
                   j/=10;
               }
        }
        printf("%d",a[0]);
        for(i=1;i<10;i++)
            printf(" %d",a[i]);
        printf("\n");
    }
    return 0;
}

  

Digit Counting UVA - 1225

标签:ati   following   ogr   sequence   seq   target   details   contain   显示   

原文地址:http://www.cnblogs.com/yongzi/p/7363051.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!