码迷,mamicode.com
首页 > 其他好文 > 详细

Investment

时间:2017-08-16 21:47:50      阅读:170      评论:0      收藏:0      [点我收藏+]

标签:store   letter   ios   tin   buying   script   cas   ase   问题   

John never knew he had a grand-uncle, until he received the notary‘s letter. He learned that his late grand-uncle had gathered a lot of money, somewhere in South-America, and that John was the only inheritor. 
John did not need that much money for the moment. But he realized that it would be a good idea to store this capital in a safe place, and have it grow until he decided to retire. The bank convinced him that a certain kind of bond was interesting for him. 
This kind of bond has a fixed value, and gives a fixed amount of yearly interest, payed to the owner at the end of each year. The bond has no fixed term. Bonds are available in different sizes. The larger ones usually give a better interest. Soon John realized that the optimal set of bonds to buy was not trivial to figure out. Moreover, after a few years his capital would have grown, and the schedule had to be re-evaluated. 
Assume the following bonds are available: 
Value Annual
interest
4000
3000
400
250

With a capital of e10 000 one could buy two bonds of $4 000, giving a yearly interest of $800. Buying two bonds of $3 000, and one of $4 000 is a better idea, as it gives a yearly interest of $900. After two years the capital has grown to $11 800, and it makes sense to sell a $3 000 one and buy a $4 000 one, so the annual interest grows to $1 050. This is where this story grows unlikely: the bank does not charge for buying and selling bonds. Next year the total sum is $12 850, which allows for three times $4 000, giving a yearly interest of $1 200. 
Here is your problem: given an amount to begin with, a number of years, and a set of bonds with their values and interests, find out how big the amount may grow in the given period, using the best schedule for buying and selling bonds.

Input

The first line contains a single positive integer N which is the number of test cases. The test cases follow. 
The first line of a test case contains two positive integers: the amount to start with (at most $1 000 000), and the number of years the capital may grow (at most 40). 
The following line contains a single number: the number d (1 <= d <= 10) of available bonds. 
The next d lines each contain the description of a bond. The description of a bond consists of two positive integers: the value of the bond, and the yearly interest for that bond. The value of a bond is always a multiple of $1 000. The interest of a bond is never more than 10% of its value.

Output

For each test case, output – on a separate line – the capital at the end of the period, after an optimal schedule of buying and selling.

Sample Input

1
10000 4
2
4000 400
3000 250

Sample Output

14050

全背包问题。
题目大意 :每一年可以出售和购买债券,求n年最大的利息本金和。

题目分析 :这里其实和0-1背包问题差不多,只是我们不在逆序遍历了,因为还是逆序的话,就又成了0-1背包了。不过也可以用记忆化搜索去做,也是可以的,不难。

技术分享
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#define maxn 2000010
using namespace std;
long long d[maxn];
struct Node
{
    int value;//价值    
    int extarl;//利息
}node[20]; 

void init()
{
    memset(d, 0, sizeof(d));
    memset(node, 0, sizeof(node));
}
int main()
{
    //freopen("in.txt", "r", stdin);
    int n,t, as = 0;
    int year;
    long long ans;    //一定要用long long
    scanf("%d", &t);
    while (t--)
    {
        init();
        scanf("%lld %d", &ans, &year);
        scanf("%d", &n);
        for (int i = 1; i <= n; i++)
        {
            scanf("%d %d", &node[i].value, &node[i].extarl);
            node[i].value /= 1000;
        }
        long long totans = ans;
        for(int k=0;k<year;k++)
        {
            if (k != 0)
                ans = totans;
            ans /= 1000;
            for(int i=1;i<=n;i++)
                for (int j = node[i].value; j <=ans; j++)//就是这个地方和0-1背包不同,可以好好想想为什么这样的话,就不一样了。
                {
                    d[j] = max(d[j], d[j - node[i].value] +node[i].extarl);
                }
            totans += d[ans];
        }
        printf("%lld\n", totans);
    }
    return 0;
}
View Code

 

 

Investment

标签:store   letter   ios   tin   buying   script   cas   ase   问题   

原文地址:http://www.cnblogs.com/7750-13/p/7375506.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!